summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 21:39:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:20 -0500
commitfeab09f72abc6d6eec16a1b8d27c231c747c0e00 (patch)
treef041dbeda8bcc1c1115197643417fecad8613ba5 /gnu/packages/gnome.scm
parent831c08d8f263f476e0293f8a5422e7314a159c91 (diff)
downloadguix-patches-feab09f72abc6d6eec16a1b8d27c231c747c0e00.tar
guix-patches-feab09f72abc6d6eec16a1b8d27c231c747c0e00.tar.gz
gnu: gtk: Replace gdk-pixbuf+svg by librsvg.
With the addition of a profile hook for computing the gdk-pixbuf loaders cache file, there is no longer a need for gdk-pixbuf+svg, and librsvg can propagate gdk-pixbuf without fear, so replace the former for the latter. The replacement was automated with the following command: $ git grep -l ',gdk-pixbuf+svg)' \ | xargs sed 's/(".*" ,gdk-pixbuf+svg)/("librsvg" ,librsvg)/' -i * gnu/packages/gtk.scm (gdk-pixbuf+svg): Delete package. (gtk+-2)[propagated-inputs]: Replace gdk-pixbuf+svg with librsvg. (gtk+)[propagated-inputs]: Likewise. * gnu/packages/gnome.scm (gdk-pixbuf+svg): Add deprecated package.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e71e28a46e..1e1f989e4b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -602,7 +602,7 @@ in JavaScript.")
("vala" ,vala)))
(inputs
`(("avahi" ,avahi)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("librsvg" ,librsvg)
("gee" ,libgee)
("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+)))
@@ -921,7 +921,7 @@ tomorrow, the rest of the week and for special occasions.")
(inputs
`(("babl" ,babl)
("cairo" ,cairo)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("librsvg" ,librsvg)
("gegl" ,gegl)
("geocode-glib" ,geocode-glib)
("gexiv2" ,gexiv2)
@@ -2821,7 +2821,7 @@ and how they are displayed (View).")
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)))
(inputs
- `(("gdk-pixbuf" ,gdk-pixbuf+svg)
+ `(("librsvg" ,librsvg)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
("pango" ,pango)
@@ -4258,7 +4258,7 @@ engineering.")
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)))
(inputs
- `(("gdk-pixbuf" ,gdk-pixbuf+svg)
+ `(("librsvg" ,librsvg)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
("pango" ,pango)
@@ -6832,7 +6832,7 @@ a secret password store, an adblocker, and a modern UI.")
(inputs
`(("avahi" ,avahi)
("gcr" ,gcr)
- ("gdk-pixbuf+svg" ,gdk-pixbuf+svg) ; for loading SVG files
+ ("librsvg" ,librsvg) ; for loading SVG files
("glib-networking" ,glib-networking)
("gnome-desktop" ,gnome-desktop)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
@@ -8712,7 +8712,7 @@ properties, screen resolution, and other GNOME parameters.")
("evolution-data-server" ,evolution-data-server)
("gcr" ,gcr)
("gdm" ,gdm)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("librsvg" ,librsvg)
("gjs" ,gjs)
("gtk" ,gtk)
("gnome-autoar" ,gnome-autoar)
@@ -8776,7 +8776,7 @@ like switching to windows and launching applications.")
("vala" ,vala)))
(inputs
`(("cairo" ,cairo)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("librsvg" ,librsvg)
("glib" ,glib)
("gnutls" ,gnutls)
("libgcrypt" ,libgcrypt)