summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 21:46:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:25 -0500
commit9c59623564fc9d74b04f2dea1130755215c608a2 (patch)
tree9c3784c422fdc573e7f834d5461826b47dc7887d /gnu/packages/gnome.scm
parentc0443cffe872c1d08119f032156cd8fe3343f5bb (diff)
downloadguix-patches-9c59623564fc9d74b04f2dea1130755215c608a2.tar
guix-patches-9c59623564fc9d74b04f2dea1130755215c608a2.tar.gz
Revert commits made to resolve a gdk-pixbuf+svg propagation issue.
Fixes <https://issues.guix.gnu.org/50957>. This reverts the following commits: - 42231bc (gnu: cheese: Propagate gdk-pixbuf+svg rather than gdk-pixbuf) - ad6a950 (gnu: mutter: Propagate gdk-pixbuf+svg rather than gdk-pixbuf) - 5e02d1a (gnu: cogl: Propagate gdk-pixbuf+svg rather than gdk-pixbuf) - 5c467b2 (gnu: libgweather: Propagate gdk-pixbuf+svg rather than gdk-pixbuf) - 26487f6 (gnu: librsvg-next: Do not propagate gdk-pixbuf) - d891922 (gnu: librsvg: Do not propagate gdk-pixbuf) - 22476d3 (gnu: libgsf: Do not propagate gdk-pixbuf) - 099ca0e (gnu: libnotify: Propagate gdk-pixbuf+svg rather than gdk-pixbuf) - fb6a1ff (gnu: appstream-glib: Propagate gdk-pixbuf+svg rather than gdk-pixbuf) - 4fb525d (gnu: weasyprint: Propagate gdk-pixbuf+svg rather than gdk-pixbuf) These commits were made to resolve a gdk-pixbuf loaders clash that could occur in a profile when both gdk-pixbuf and gdk-pixbuf+svg were propagated. Unfortunately, librsvg really needs to propagate gdk-pixbuf itself, which would introduce a cycle. Packages such as 'efl' were broken as a result of not propagating gdk-pixbuf. A more definitive fix will be proposed for core-updates, which includes a profile hook to generate the gdk-pixbuf loaders.cache file, as well as a build phase and search path specification, that should resolve the issue for good.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1aff9d26a0..a8280ebfe5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3104,7 +3104,7 @@ configuring CUPS.")
#t)))))
(propagated-inputs
`(;; In Requires of libnotify.pc.
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)))
(inputs
`(("gtk+" ,gtk+)
@@ -3553,7 +3553,6 @@ for dealing with different structured file formats.")
`(("bzip2" ,bzip2)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
- ("gdk-pixbuf" ,gdk-pixbuf)
("harfbuzz" ,harfbuzz)
("libcroco" ,libcroco)
("libgsf" ,libgsf)
@@ -3561,6 +3560,7 @@ for dealing with different structured file formats.")
("pango" ,pango)))
(propagated-inputs
`(("cairo" ,cairo)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)))
(synopsis "SVG rendering library")
(description "Librsvg is a library to render SVG images to Cairo surfaces.
@@ -5483,7 +5483,7 @@ service via the system message bus.")
;; gweather-3.0.pc refers to GTK+, GDK-Pixbuf, GLib/GObject, libxml, and
;; libsoup.
`(("gtk+" ,gtk+)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("libxml2" ,libxml2)
("libsoup" ,libsoup)
("geocode-glib" ,geocode-glib)))
@@ -5745,7 +5745,7 @@ throughout GNOME for API documentation).")
("pkg-config" ,pkg-config)))
(propagated-inputs
`(("glib" ,glib)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("libx11" ,libx11)
("libxext" ,libxext)
("libxfixes" ,libxfixes)
@@ -7429,7 +7429,7 @@ to display dialog boxes from the commandline and shell scripts.")
;; mutter-clutter-1.0.pc and mutter-cogl-1.0.pc refer to these:
("atk" ,atk)
("cairo" ,cairo)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)
("json-glib" ,json-glib)
("libinput" ,libinput)
@@ -10607,7 +10607,7 @@ photo-booth-like software, such as Cheese.")
("clutter-gst" ,clutter-gst)
("clutter-gtk" ,clutter-gtk)
("libcanberra" ,libcanberra)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)
("gstreamer" ,gstreamer)))
(inputs