summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorL p R n d n <guix@lprndn.info>2019-09-02 15:15:31 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-01 22:21:17 +0200
commit5f39050b1eb74d371bd1ddabeb40d4339cc35158 (patch)
treefc5086cca9837c1d9e74b0d9e3f816a6a5479246 /gnu/packages/gnome.scm
parent5042f33e3bf226fd06159953f8fdfb27b95c5ee0 (diff)
downloadguix-patches-5f39050b1eb74d371bd1ddabeb40d4339cc35158.tar
guix-patches-5f39050b1eb74d371bd1ddabeb40d4339cc35158.tar.gz
gnu: libxklavier: Update to 5.4.
* gnu/packages/gnome.scm (libxklavier): Update to 5.4. [source] Switch to git source. [arguments] Add no-configure phase. Disable xmodmap in #:configure-flags. [inputs] Add which, intltool, gtk-doc, which, automake, autoconf and libtool. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 24 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a30fc8460c..efe5206e53 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2537,24 +2537,40 @@ and objects.")
(define-public libxklavier
(package
(name "libxklavier")
- (version "5.3")
+ (version "5.4")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- version "/" name "-" version ".tar.xz"))
+ ;; Note: There's no tarball at ftp.gnome.org for this version.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://anongit.freedesktop.org/git/libxklavier")
+ (commit (string-append "libxklavier-" version))))
(sha256
(base32
- "016lpdv35z0qsw1cprdc2k5qzkdi5waj6qmr0a2q6ljn9g2kpv7b"))))
+ "1w1x5mrgly2ldiw3q2r6y620zgd89gk7n90ja46775lhaswxzv7a"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'no-configure
+ (lambda* _
+ (setenv "NOCONFIGURE" "1")
+ #t)))
+ #:configure-flags
(list (string-append "--with-xkb-base="
(assoc-ref %build-inputs "xkeyboard-config")
- "/share/X11/xkb"))))
+ "/share/X11/xkb")
+ "--disable-xmodmap-support")))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("gtk-doc" ,gtk-doc)
+ ("intltool" ,intltool)
+ ("which" ,which)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(propagated-inputs
;; Required by libxklavier.pc.
`(("glib" ,glib)