summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-12 22:12:33 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-12 22:29:53 -0500
commitce7d93ceda06f0332617a29fe0181f13d2c0b369 (patch)
treed2cd9b5bed72c1fc697461971ed494008bf88ea9 /gnu/packages/gnome.scm
parent1de8c00a7b743440943356bb086caaad58d489e9 (diff)
downloadguix-patches-ce7d93ceda06f0332617a29fe0181f13d2c0b369.tar
guix-patches-ce7d93ceda06f0332617a29fe0181f13d2c0b369.tar.gz
gnu: evolution-data-server: Update to 3.42.1.
* gnu/packages/gnome.scm (evolution-data-server): Update to 3.42.1. Delete trailing #t. [origin]: Remove patches. [phases]{adjust-webkitgtk-version}: New phase. * gnu/packages/patches/evolution-data-server-CVE-2020-14928.patch: Likewise. * gnu/packages/patches/evolution-data-server-CVE-2020-16117.patch: Likewise. * gnu/packages/patches/evolution-data-server-libical-compat.patch: Likewise. * gnu/packages/patches/evolution-data-server-locales.patch: Likewise. * gnu/packages/patches/evolution-data-server-printableoptions.patch: Likewise. * gnu/local.mk (dist_patch_DATA): De-register them.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2340d2b391..73f9dd1bfe 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7614,21 +7614,15 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
(define-public evolution-data-server
(package
(name "evolution-data-server")
- (version "3.34.2")
+ (version "3.42.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
- (patches
- (search-patches "evolution-data-server-locales.patch"
- "evolution-data-server-libical-compat.patch"
- "evolution-data-server-CVE-2020-14928.patch"
- "evolution-data-server-CVE-2020-16117.patch"
- "evolution-data-server-printableoptions.patch"))
(sha256
- (base32 "16z85y6hhazcrp5ngw47w4x9r0j8zrj7awv5im58hhp0xs19zf1y"))))
+ (base32 "0a7my8spwcaf2i2fz8ndddi1drv6l9gxq0qblmnkxzyhfwm7zrp6"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -7648,33 +7642,36 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
"-DENABLE_INTROSPECTION=ON")) ;required for Vala bindings
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'adjust-webkitgtk-version
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("webkit2gtk-4.0")
+ "webkit2gtk-4.1"))))
(add-after 'unpack 'disable-failing-tests
(lambda _
;; tests/book-migration/test-migration.c:160:test_fetch_contacts:
;; assertion failed (g_slist_length (contacts) == 20): (0 == 20)
(delete-file-recursively "tests/book-migration")
(substitute* "tests/CMakeLists.txt"
- (("add_subdirectory\\(book-migration\\)") ""))
- #t))
+ (("add_subdirectory\\(book-migration\\)") ""))))
(add-after 'unpack 'patch-paths
(lambda _
(substitute* '("tests/test-server-utils/e-test-server-utils.c"
"tests/libedata-book/data-test-utils.c"
"tests/libedata-book/test-book-cache-utils.c"
"tests/libedata-cal/test-cal-cache-utils.c")
- (("/bin/rm") (which "rm")))
- #t))
+ (("/bin/rm") (which "rm")))))
(add-before 'configure 'dont-override-rpath
(lambda _
(substitute* "CMakeLists.txt"
;; CMakeLists.txt hard-codes runpath to just the libdir.
;; Remove it so the configure flag is respected.
- (("SET\\(CMAKE_INSTALL_RPATH .*") ""))
- #t)))))
+ (("SET\\(CMAKE_INSTALL_RPATH .*") "")))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)
("gperf" ,gperf)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("vala" ,vala)