summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJosselin Poiret <josselin.poiret@protonmail.ch>2021-09-13 07:45:06 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 17:17:44 +0000
commit5c3f0c3e03757b6653f4c2386a526a2d9d6532f7 (patch)
tree198208aa5bf83200d37abee56ce724e2b78d8ea4 /gnu/packages/gnome.scm
parentfc24bcb86fb68e1e69c168d5de7d94f01148c9cd (diff)
downloadguix-patches-5c3f0c3e03757b6653f4c2386a526a2d9d6532f7.tar
guix-patches-5c3f0c3e03757b6653f4c2386a526a2d9d6532f7.tar.gz
gnu: Add Wayland support for GDM.
Add the optional flag `wayland?` in `gdm-configuration` to launch GDM with Wayland, enabling the use of Wayland sessions with GDM. * gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (gdm): Use it. * gnu/services/xorg.scm (<gdm-configuration>)[wayland?]: New field. (gdm-configuration): Honor it. (gdm-shepherd-service): Add the XCURSOR_PATH environment variable. * doc/guix.texi (X Window): Document it Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cf3a4e79fa..f0a8a4265d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8148,7 +8149,8 @@ library.")
(patches
(search-patches
"gdm-default-session.patch"
- "gdm-elogind-support.patch"))))
+ "gdm-elogind-support.patch"
+ "gdm-remove-hardcoded-xwayland-path.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t