summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-21 22:53:21 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-21 23:01:15 +0100
commitf862d7fb8d3656e7e0ec8ff5ef97db8e46536e93 (patch)
tree786b5616ee35090518d2e2b7fbde0f3ebe503155 /gnu/packages/gnome.scm
parent84c3aafb5a18ad278bbb36df7b70849fe05789c8 (diff)
downloadguix-patches-f862d7fb8d3656e7e0ec8ff5ef97db8e46536e93.tar
guix-patches-f862d7fb8d3656e7e0ec8ff5ef97db8e46536e93.tar.gz
gnu: network-manager: Build with Meson 0.60.
This is another way to address <https://github.com/mesonbuild/meson/issues/9492> as suggested by Nirbheek Chauhan and Paolo Bonzini. * gnu/packages/patches/network-manager-meson.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (network-manager)[source]: Use it. [arguments]: Remove #:meson.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e6e6092593..82b002bd0d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7899,7 +7899,8 @@ users.")
(uri (string-append "mirror://gnome/sources/NetworkManager/"
(version-major+minor version) "/"
"NetworkManager-" version ".tar.xz"))
- (patches (search-patches "network-manager-plugin-path.patch"))
+ (patches (search-patches "network-manager-plugin-path.patch"
+ "network-manager-meson.patch"))
(sha256
(base32
"0jzmz0zw64dgvdn2g7pppr7bkywpbxcbdb1viv6p7zh2lnh3dax8"))))
@@ -7907,10 +7908,7 @@ users.")
(outputs '("out"
"doc")) ; 8 MiB of gtk-doc HTML
(arguments
- ;; Use meson-0.59, otherwise the custom rpaths are not registered
- ;; correctly (see: https://github.com/mesonbuild/meson/issues/9492).
- `(#:meson ,meson-0.59
- #:configure-flags
+ `(#:configure-flags
(let ((out (assoc-ref %outputs "out"))
(dhclient (search-input-file %build-inputs "/sbin/dhclient")))
(list