summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-02 13:15:31 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-02 14:59:56 +0100
commitd371abbd0f46461aa8210de8140f95aad05e9e7e (patch)
tree3a051abffb815b6ffcb08d108d1285ab02ea655b /gnu/packages/gnome.scm
parent8477a6d743f3068e449402ade739355878242377 (diff)
downloadguix-patches-d371abbd0f46461aa8210de8140f95aad05e9e7e.tar
guix-patches-d371abbd0f46461aa8210de8140f95aad05e9e7e.tar.gz
gnu: librsvg: Add 'librsvg-for-system' procedure.
* gnu/packages/gnome.scm (librsvg-for-system): New procedure.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fd67be7a42..727d0617ec 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3679,6 +3679,17 @@ diagrams.")
(synopsis "Render SVG files using Cairo (ancient C version)")
(properties '((hidden? . #t)))))
+(define* (librsvg-for-system #:optional
+ (system (or (%current-target-system)
+ (%current-system))))
+ ;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
+ ;; on x86_64 so far, use the ancient C version on other platforms (FIXME).
+ (if (string-prefix? "x86_64-" system)
+ librsvg
+ librsvg-2.40))
+
+(export librsvg-for-system)
+
(define-public libidl
(package
(name "libidl")