summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-19 15:17:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-20 08:57:01 -0500
commitafacad8b67d624b2b0f206acb7233785a296be7c (patch)
treeba40724f401c2a1a86f1cecfc60c181cfb73537a /gnu/packages/gnome.scm
parentb342b68c83a0231fd35cf205a94b754d10ff162e (diff)
downloadguix-patches-afacad8b67d624b2b0f206acb7233785a296be7c.tar
guix-patches-afacad8b67d624b2b0f206acb7233785a296be7c.tar.gz
gnu: gnome-shell: Update to 41.0.
* gnu/packages/gnome.scm (gnome-shell): Update to 41.0. [origin]: Remove patches and modules fields. [phases]{pre-check}: Set HOME. * gnu/packages/patches/gnome-shell-disable-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8c3ad06856..ebe718ab4a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8753,7 +8753,7 @@ properties, screen resolution, and other GNOME parameters.")
(define-public gnome-shell
(package
(name "gnome-shell")
- (version "40.5")
+ (version "41.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -8761,9 +8761,7 @@ properties, screen resolution, and other GNOME parameters.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0kph3g4ix23sm3ip2b13rs7hx8sa7fvlvcyy4zdk2iaj56rmadvd"))
- (patches (search-patches "gnome-shell-disable-test.patch"))
- (modules '((guix build utils)))))
+ "0ragmcln210zvzhc2br33yprbkj9drjzd7inp5sdxra0a7l73yaj"))))
(build-system meson-build-system)
(arguments
`(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
@@ -8811,7 +8809,8 @@ properties, screen resolution, and other GNOME parameters.")
(lambda* (#:key inputs #:allow-other-keys)
;; Tests require a running X server.
(system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")))
+ (setenv "DISPLAY" ":1")
+ (setenv "HOME" "/tmp"))) ;to avoid "fatal" warnings
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))