summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-30 00:03:07 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-01 10:01:38 +0100
commit89907521ef2f8845f13369b95376cefa22a9320d (patch)
treea3992f074f399fab3496d96ae7450d582828ff7c /gnu/packages/gnome.scm
parent854120d01ffe8b209fa8d897ba0fcf39ce2cdf32 (diff)
downloadguix-patches-89907521ef2f8845f13369b95376cefa22a9320d.tar
guix-patches-89907521ef2f8845f13369b95376cefa22a9320d.tar.gz
gnu: devhelp: Add a libsoup 2 variant.
* gnu/packages/gnome.scm (devhelp-with-libsoup2): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8e0e750180..ccb99ca8ec 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5854,6 +5854,22 @@ natively with GTK-Doc (the API reference system developed for GTK+ and used
throughout GNOME for API documentation).")
(license license:gpl2+)))
+(define-public devhelp-with-libsoup2
+ (package/inherit devhelp
+ (arguments
+ (substitute-keyword-arguments (package-arguments devhelp)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson/meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))))))))
+ (inputs
+ `(("amtk" ,amtk)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("webkitgtk" ,webkitgtk-with-libsoup2)))))
+
(define-public cogl
(package
(name "cogl")