summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-24 18:22:08 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-24 18:44:26 +0100
commit3e810b846ab10eca86f8c6c7a3815954f1b77ebd (patch)
tree0e2eff16951a70bd84ca0c88361061942a694e8f /gnu/packages/gnome.scm
parentdda78c1de7bd4cf035b51b892fd85f4daf484712 (diff)
downloadguix-patches-3e810b846ab10eca86f8c6c7a3815954f1b77ebd.tar
guix-patches-3e810b846ab10eca86f8c6c7a3815954f1b77ebd.tar.gz
gnu: glib-networking: Work around test failure on 32-bit platforms.
On 32-bit platforms with a 32-bit 'time_t', we'd get this test failure: GLib-Net:ERROR:../glib-networking-2.70.rc/tls/tests/certificate.c:689:test_certificate_not_valid_after: assertion failed (actual_str == EXPECTED_NOT_VALID_AFTER): ("2037-12-31T23:23:23Z" == "2046-07-25T18:13:10Z") This commit includes the workaround implemented upstream. * gnu/packages/patches/glib-networking-32-bit-time.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (glib-networking)[arguments]: New field.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6d56d04915..492cebd304 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4845,6 +4845,17 @@ library.")
(patches
(search-patches "glib-networking-gnutls-binding.patch"))))
(build-system meson-build-system)
+ (arguments
+ (if (target-64bit?)
+ '()
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'work-around-32-bit-time-t
+ (lambda _
+ (invoke "patch" "--force" "-p1" "-i"
+ #$(local-file
+ (search-patch
+ "glib-networking-32-bit-time.patch")))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)))