summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2013-12-28 08:19:42 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-29 18:53:25 +0100
commited19903d56fe0f172b04bbeafb6ac885260e5a19 (patch)
tree7418ed4c50f0d85db69be4221238da53157ed49d /gnu/packages/gnome.scm
parent96e5085c8113a8ccfdb627b8e2efe30364a86563 (diff)
downloadguix-patches-ed19903d56fe0f172b04bbeafb6ac885260e5a19.tar
guix-patches-ed19903d56fe0f172b04bbeafb6ac885260e5a19.tar.gz
gnu: gnome: Add new package gtkglext
* gnu/packages/gnome.scm (gtkglext): New variable. * gnu/packages/patches/gtkglext-disable-disable-deprecated.patch, gnu/packages/patches/gtkglext-remove-pangox-dependency.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 609310efa5..5d590a95c9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -21,6 +21,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gstreamer)
@@ -468,3 +469,29 @@ demand (lazy) programming language support for C, Python and JS; simplicity of
the API")
(license lgpl2.0+)))
+
+(define-public gtkglext
+ (package
+ (name "gtkglext")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/project/gtkglext/gtkglext/"
+ version "/gtkglext-" version ".tar.gz"))
+ (sha256
+ (base32 "1ya4d2j2aacr9ii5zj4ac95fjpdvlm2rg79mgnk7yvl1dcy3y1z5"))
+ (patches (list
+ (search-patch "gtkglext-remove-pangox-dependency.patch")
+ (search-patch "gtkglext-disable-disable-deprecated.patch")))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+-2)
+ ("mesa" ,mesa)
+ ("libx11" ,libx11)
+ ("libxt" ,libxt)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://projects.gnome.org/gtkglext")
+ (synopsis "OpenGL extension to GTK+.")
+ (description "GtkGLExt is an OpenGL extension to GTK+. It provides
+additional GDK objects which support OpenGL rendering in GTK+ and GtkWidget
+API add-ons to make GTK+ widgets OpenGL-capable.")
+ (license lgpl2.1+)))