summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2020-12-14 23:31:39 -0800
committerEfraim Flashner <efraim@flashner.co.il>2021-01-05 17:06:32 +0200
commit957f0c40327ce00f53db22737e3775ce616ac258 (patch)
tree562c6b566e620022eb9ef2e43022968c6cca67e3 /gnu/packages/gnome.scm
parenteffacc281c758236bbba9a1f4fd7791baa303a96 (diff)
downloadguix-patches-957f0c40327ce00f53db22737e3775ce616ac258.tar
guix-patches-957f0c40327ce00f53db22737e3775ce616ac258.tar.gz
gnu: terminator: Update to 1.92.
* gnu/packages/gnome.scm (terminator): Update to 1.92. [source]: Use new upstream URI. [inputs]: Remove python2-psutil. Replace python2-pycairo, python2-pygobject with python- versions. Add dbus-glib, gtk+. Move gobject-introspection ... [native-inputs]: ... to here. Add python-psutil, python-pytest-runner, python-pytest. [propagated-inputs]: Add pyhton-configobj. [arguments]: Build with python3. Adjust 'wrap-program phase to also wrap with package's own python output. [home-page]: Update to new upstream URI. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm43
1 files changed, 27 insertions, 16 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 634b251031..f0d94ab1fe 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2020 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10859,32 +10860,37 @@ advanced image management tool")
(define-public terminator
(package
(name "terminator")
- (version "1.91")
+ (version "1.92")
(source (origin
(method url-fetch)
- (uri (string-append "https://launchpad.net/" name "/"
- "gtk3/" version "/" "+download/"
+ (uri (string-append "https://github.com/gnome-" name "/" name "/"
+ "releases/download/v" version "/"
name "-" version ".tar.gz"))
(sha256
(base32
- "0sdyqwydmdnh7j6mn74vrywz35m416kqsbxbrqcnv5ak08y6xxwm"))))
+ "1wbkfp0nk6x9bcwi681zy30qmrp4h754sdz6b7hi9j22mmvdd50z"))))
(build-system python-build-system)
(native-inputs
- `(("intltool" ,intltool)
+ `(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("python-psutil" ,python-psutil)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-pytest" ,python-pytest)))
(inputs
`(("cairo" ,cairo)
- ("gobject-introspection" ,gobject-introspection)
+ ("dbus-glib" ,dbus-glib)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("python2-pycairo" ,python2-pycairo)
- ("python2-pygobject" ,python2-pygobject)
- ("python2-psutil" ,python2-psutil)
+ ("gtk+" ,gtk+)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)
("vte" ,vte)))
+ (propagated-inputs
+ `(("python-configobj" ,python-configobj)))
(arguments
- `(#:python ,python-2 ; Python 3 isn't supported
- #:imported-modules ((guix build glib-or-gtk-build-system)
+ `(#:imported-modules ((guix build glib-or-gtk-build-system)
,@%python-build-system-modules)
#:modules ((guix build python-build-system)
((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
@@ -10895,14 +10901,19 @@ advanced image management tool")
'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let ((prog (string-append (assoc-ref outputs "out")
- "/bin/terminator")))
+ "/bin/terminator"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
(wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH")))
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t)))
(add-after 'wrap-program 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
- (home-page "https://gnometerminator.blogspot.com/")
+ (home-page "https://gnome-terminator.org/")
(synopsis "Store and run multiple GNOME terminals in one window")
(description
"Terminator allows you to run multiple GNOME terminals in a grid and