summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-24 18:02:27 -0400
committerLeo Famulari <leo@famulari.name>2017-05-24 18:02:27 -0400
commit38f1163c955945e92ba4d48c6f7c233c7a2aac1f (patch)
tree19c19ef24df71475d89b648fd3a34dacfe78fdcb /gnu/packages/gnome.scm
parent9269ce492576a9fbb5aa39548f03dab9207fb8e9 (diff)
parentff51a87cae360334ed42c79c3e4e46fb7c121eb2 (diff)
downloadguix-patches-38f1163c955945e92ba4d48c6f7c233c7a2aac1f.tar
guix-patches-38f1163c955945e92ba4d48c6f7c233c7a2aac1f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6990ab564a..45aa80176c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1745,7 +1745,7 @@ engineering.")
(define-public gnome-themes-standard
(package
(name "gnome-themes-standard")
- (version "3.22.2")
+ (version "3.22.3")
(source
(origin
(method url-fetch)
@@ -1754,7 +1754,7 @@ engineering.")
version ".tar.xz"))
(sha256
(base32
- "19bxw69ms46px5xgvwbjlhq2vkmrqfx2az49q63w2wxqb76icidk"))))
+ "0smmiamrgcgf5sa88bsn8hwmvsyx4gczzs359nwxbkv14b2qgp31"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -2973,7 +2973,7 @@ without stepping on each others toes.")
(define-public clutter
(package
(name "clutter")
- (version "1.26.0")
+ (version "1.26.2")
(source
(origin
(method url-fetch)
@@ -2982,7 +2982,7 @@ without stepping on each others toes.")
name "-" version ".tar.xz"))
(sha256
(base32
- "01nfjd4k7j2n3agpx2d9ncff86nfsqv4n23465rb9zmk4iw4wlb7"))))
+ "0mif1qnrpkgxi43h7pimim6w6zwywa16ixcliw0yjm9hk0a368z7"))))
;; NOTE: mutter exports a bundled fork of clutter, so when making changes
;; to clutter, corresponding changes may be appropriate in mutter as well.
(build-system gnu-build-system)
@@ -3057,7 +3057,7 @@ presentations, kiosk style applications and so on.")
(define-public clutter-gst
(package
(name "clutter-gst")
- (version "3.0.22")
+ (version "3.0.24")
(source
(origin
(method url-fetch)
@@ -3066,7 +3066,7 @@ presentations, kiosk style applications and so on.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1m6zwc7xr7lmbwiqav961g7jhc7gp5gb73dm6j93szpa6bxmgz7i"))))
+ "0v6cg0syh4vx7y7ni47jsvr2r57q0j3h1f1gjlp0ciscixywiwg9"))))
(build-system gnu-build-system)
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
@@ -3088,7 +3088,7 @@ GL based interactive canvas library.")
(define-public libchamplain
(package
(name "libchamplain")
- (version "0.12.14")
+ (version "0.12.15")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3096,7 +3096,7 @@ GL based interactive canvas library.")
version ".tar.xz"))
(sha256
(base32
- "13snnka1jqc5qrgij8bm22xy02pncf3dn5ij3jh4rrpzq7g1sqpi"))))
+ "0x5qa1aw1y59lzkmf4j4szspn49341a87vcja4ydgxny1chilwjl"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--enable-vala")))
(native-inputs
@@ -3935,7 +3935,7 @@ wraps things up in a developer-friendly way.")
(define-public libgee
(package
(name "libgee")
- (version "0.18.1")
+ (version "0.20.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3943,7 +3943,7 @@ wraps things up in a developer-friendly way.")
name "-" version ".tar.xz"))
(sha256
(base32
- "18ir5264bhdg76kcjn8i5bfs1vz89qqn2py20aavm2cwbaz6ns4r"))))
+ "1fy24dr8imrjlmsqj1syn0gi139gba6hwk3j5vd6sr3pxniqnc11"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -4860,7 +4860,7 @@ providing graphical log-ins and managing local and remote displays.")
(define-public libgtop
(package
(name "libgtop")
- (version "2.34.1")
+ (version "2.36.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4868,7 +4868,7 @@ providing graphical log-ins and managing local and remote displays.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1qh9srg8pqmrsl12mwnclncs7agmjjvx3q6v5qwqvcb2cskpi6f8"))))
+ "0ax17c7nplghxgsf8zl92nmhkbnggj62wwzl7nq00aqb2m6f7gqk"))))
(build-system gnu-build-system)
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -5112,7 +5112,7 @@ as SASL, TLS and VeNCrypt. Additionally it supports encoding extensions.")
(define-public gnome-autoar
(package
(name "gnome-autoar")
- (version "0.1.1")
+ (version "0.2.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5120,7 +5120,7 @@ as SASL, TLS and VeNCrypt. Additionally it supports encoding extensions.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1jcs6jgysg9n3zi3d1l4iqddzmczfdcvz7vkxn607p32nl8bhp7n"))))
+ "0qnafiwgajsaryh669lfclb4f6z5n1r9r4zhig1ha0ykxq32rzp1"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("gnome-common" ,gnome-common)
@@ -5141,7 +5141,7 @@ easy, safe, and automatic.")
(define-public tracker
(package
(name "tracker")
- (version "1.10.3")
+ (version "1.12.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5149,7 +5149,7 @@ easy, safe, and automatic.")
name "-" version ".tar.xz"))
(sha256
(base32
- "03ch3ndmxghfr9wnw9hfmpkjfa7k5v5cwwf3y1ja6ihk3c5avgbb"))))
+ "0vsrzzkcfvmylhpk1ww6xdx8z9sgjs0gn74gz82qngjyq3c3s6c3"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("gnome-common" ,gnome-common)
@@ -5176,13 +5176,14 @@ easy, safe, and automatic.")
("exempi" ,exempi)
("libxml2" ,libxml2)
("upower" ,upower)
- ("libgee" ,libgee)
("libunistring" ,libunistring)
("giflib" ,giflib)
+ ("json-glib" ,json-glib)
("openjpeg" ,openjpeg-1)
("libosinfo" ,libosinfo)
("libcue" ,libcue)
("libseccomp" ,libseccomp)
+ ("libsoup" ,libsoup)
("libuuid" ,util-linux)))
(arguments `(#:tests? #f)) ; XXX FIXME enable tests (some fail)
(synopsis "Metadata database, indexer and search tool")
@@ -5812,7 +5813,7 @@ GLib/GObject code.")
(define-public libgnomekbd
(package
(name "libgnomekbd")
- (version "3.22.0")
+ (version "3.22.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5820,7 +5821,7 @@ GLib/GObject code.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1pvpbljvxc0riamraiflnm05dpb6i4vlmqqgdh74xggbpzd302rl"))))
+ "1plkkack6s8b21gcmmly0lapgcjz53dmw2vixnn4rw4jxjwbdzaf"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)