summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-13 22:49:52 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-13 22:50:11 +0200
commitc1354b90e98538e890bc9388527e540a513a0d53 (patch)
tree5abc2aff7a8b585fd1ef1f6610b47dfe5186e5e6 /gnu/packages/gnome.scm
parent8db824ba3102b6941d3fbf32ec2f5e598c71422d (diff)
downloadguix-patches-c1354b90e98538e890bc9388527e540a513a0d53.tar
guix-patches-c1354b90e98538e890bc9388527e540a513a0d53.tar.gz
gnu: Add libgnome-keyring and Evince.
* gnu/packages/gnome.scm (libgnome-keyring, evince): New variables.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm93
1 files changed, 91 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e7dbfc75cb..16e491d3ed 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -17,14 +17,16 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gnome)
- #:use-module ((guix licenses) #:select (gpl2 gpl2+ lgpl2.1+ lgpl3))
+ #:use-module ((guix licenses) #:select (gpl2 gpl2+ lgpl2.0+ lgpl2.1+ lgpl3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages glib)
- #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages pdf)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libpng)
#:use-module (gnu packages perl)
@@ -98,6 +100,93 @@ Gnome project. It includes xml2po tool which makes it easier to translate
and keep up to date translations of documentation.")
(license gpl2+))) ; xslt under lgpl
+(define-public libgnome-keyring
+ (package
+ (name "libgnome-keyring")
+ (version "3.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/libgnome-keyring/3.6/libgnome-keyring-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "0c4qrjpmv1hqga3xv6wsq2z10x2n78qgw7q3k3s01y1pggxkgjkd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)))
+ (inputs
+ `(("pkg-config" ,pkg-config)
+ ("libgcrypt" ,libgcrypt)
+ ("dbus" ,dbus)))
+ (propagated-inputs
+ ;; Referred to in .h files and .pc.
+ `(("glib" ,glib)))
+ (home-page "http://www.gnome.org")
+ (synopsis "Accessing passwords from the GNOME keyring")
+ (description
+ "Client library to access passwords from the GNOME keyring.")
+
+ ;; Though a couple of files are LGPLv2.1+.
+ (license lgpl2.0+)))
+
+(define-public evince
+ (package
+ (name "evince")
+ (version "3.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/evince/3.6/evince-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "1da1pij030dh8mb0pr0jnyszgsbjnh8lc17rj5ii52j3kmbv51qv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-nautilus")
+
+ ;; FIXME: Tests fail with:
+ ;; ImportError: No module named gi.repository
+ ;; Where should that module come from?
+ #:tests? #f ))
+ (inputs
+ `(("libspectre" ,libspectre)
+ ;; ("djvulibre" ,djvulibre)
+ ("ghostscript" ,ghostscript)
+ ("poppler" ,poppler)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("libgnome-keyring" ,libgnome-keyring)
+ ("gnome-icon-theme" ,gnome-icon-theme)
+ ("itstool" ,itstool)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("atk" ,atk)
+ ("pango" ,pango)
+ ("gtk+" ,gtk+)
+ ("glib" ,glib)
+ ("libxml2" ,libxml2)
+ ("perl-xml-parser" ,perl-xml-parser)
+ ("perl" ,perl)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("libsm" ,libsm)
+ ("libice" ,libice)
+
+ ;; For tests.
+ ("dogtail" ,python2-dogtail)))
+ (home-page
+ "http://www.gnome.org/projects/evince/")
+ (synopsis "GNOME's document viewer")
+ (description
+ "Evince is a document viewer for multiple document formats. It
+currently supports PDF, PostScript, DjVu, TIFF and DVI. The goal
+of Evince is to replace the multiple document viewers that exist
+on the GNOME Desktop with a single simple application.
+")
+ (license gpl2+)))
+
(define-public gsettings-desktop-schemas
(package
(name "gsettings-desktop-schemas")