summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-11 02:02:24 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-11 02:02:24 +0100
commite940f6d80193dd70ecd28b93e8d85042aa33a7c8 (patch)
tree29d9ad1ffb6b98919308368a85198e9bf19f27c9 /gnu/packages/gnome.scm
parenta2943e36c7c6309e955708552a72d532844576a8 (diff)
downloadguix-patches-e940f6d80193dd70ecd28b93e8d85042aa33a7c8.tar
guix-patches-e940f6d80193dd70ecd28b93e8d85042aa33a7c8.tar.gz
gnu: libcroco: Fix CVE-2020-12825.
* gnu/packages/patches/libcroco-CVE-2020-12825.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gnome.scm (libcroco/fixed): New variable. Apply patch. (libcroco)[replacement]: Graft.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5ee28eec03..a0796b0115 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3227,6 +3227,7 @@ the GNOME desktop environment.")
(sha256
(base32
"1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))))
+ (replacement libcroco/fixed)
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -3245,6 +3246,21 @@ XML/CSS rendering engine.")
;; LGPLv2.1-only.
(license license:lgpl2.1)))
+(define-public libcroco/fixed
+ (package
+ (inherit libcroco)
+ (name "libcroco")
+ (version "0.6.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))
+ (patches (search-patches "libcroco-CVE-2020-12825.patch"))))))
+
(define-public libgsf
(package
(name "libgsf")