summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-18 21:14:19 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:35 -0500
commit2080f55590f0a3d8f766754e19999a91a9f71f58 (patch)
tree6bfc2cabb1aaa0078bc8e361eb0293ddc72ed1d8 /gnu/packages/gnome.scm
parentee16c5a6856a88ebc3921ba258d93da0e3d250c5 (diff)
downloadguix-patches-2080f55590f0a3d8f766754e19999a91a9f71f58.tar
guix-patches-2080f55590f0a3d8f766754e19999a91a9f71f58.tar.gz
gnu: gsettings-desktop-schemas: Add python to native inputs.
Since commit 5d20d7e1369fc7d93de19c0bd219937d697ceae6, meson no longer propagates Python, which is the reason this change is now needed here. * gnu/packages/gnome.scm (gsettings-desktop-schemas) [phases]{patch-schemas}: Use 'search-input-directory'. [native-inputs]: Use new style and add python.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1ac80bb98f..2779b65666 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2661,25 +2661,24 @@ on the GNOME Desktop with a single simple application.")
"1v9jagk679m01nji0acirynxinziv036618c7xc49l4nwmr9ja3p"))))
(build-system meson-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(#:phases (modify-phases %standard-phases
(add-after 'unpack 'patch-schemas
(lambda* (#:key inputs #:allow-other-keys)
- (let ((theme (assoc-ref inputs "gnome-backgrounds")))
- (substitute* (find-files "schemas"
- "\\.gschema\\.xml\\.in$")
- ;; Provide the correct file name of the default
- ;; GNOME background, 'adwaita-timed.xml'.
- (("@datadir@/backgrounds/gnome")
- (string-append theme "/share/backgrounds/gnome"))
- ;; Do not reference fonts, that may not exist.
- (("'Source Code Pro 10'") "'Monospace 11'"))))))))
- (inputs
- (list glib gnome-backgrounds))
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib" ,glib "bin") ; glib-compile-schemas, etc.
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)))
+ (substitute* (find-files "schemas"
+ "\\.gschema\\.xml\\.in$")
+ ;; Provide the correct file name of the default
+ ;; GNOME background, 'adwaita-timed.xml'.
+ (("@datadir@/backgrounds/gnome")
+ (search-input-directory inputs
+ "/share/backgrounds/gnome"))
+ ;; Do not reference fonts, that may not exist.
+ (("'Source Code Pro 10'") "'Monospace 11'")))))))
+ (inputs (list glib gnome-backgrounds))
+ (native-inputs (list gettext-minimal
+ `(,glib "bin") ;glib-compile-schemas, etc.
+ gobject-introspection
+ pkg-config
+ python)) ;for build-aux/meson/post-install.py
(home-page "https://launchpad.net/gsettings-desktop-schemas")
(synopsis "GNOME settings for various desktop components")
(description "Gsettings-desktop-schemas contains a collection of GSettings