summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-06 17:05:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:43:17 +0100
commit8356aefafc9ccd40874b2eb46644d996a00b8fc2 (patch)
tree7e4fac4fc9b4b55c61d99f58b91e249e2a9fc705 /gnu/packages/gnome.scm
parent80d1e4c0f7628e032d5c11a78bd8eff82893a6b6 (diff)
downloadguix-patches-8356aefafc9ccd40874b2eb46644d996a00b8fc2.tar
guix-patches-8356aefafc9ccd40874b2eb46644d996a00b8fc2.tar.gz
gnu: gnome-screenshot: Update to 3.26.0.
* gnu/packages/gnome.scm (gnome-screenshot): Update to 3.26.0. [build-system]: Use meson-build-system. [native-inputs]: Add gtk+:bin, desktop-file-utils, and appstream-glib.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ec26744bb6..3e0d2f4daa 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6091,7 +6091,7 @@ can add your own files to the collection.")
(define-public gnome-screenshot
(package
(name "gnome-screenshot")
- (version "3.22.0")
+ (version "3.26.0")
(source
(origin
(method url-fetch)
@@ -6100,11 +6100,14 @@ can add your own files to the collection.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0c02n1hgv21m4082jx399b1yazsc0cr07ba8k0pv8v3w7i5z21ca"))))
- (build-system glib-or-gtk-build-system)
+ "1fy8fjl29i3xhj8caik03d3za06x96xgkk8r4fwz88iqbmci3g0v"))))
+ (build-system meson-build-system)
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
+ ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("intltool" ,intltool)
+ ("appstream-glib" ,appstream-glib)
("pkg-config" ,pkg-config)))
(inputs
`(("gtk+" ,gtk+)