summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorUko Kokņevičs <perkontevs@gmail.com>2019-05-20 02:23:30 +0300
committerMarius Bakke <mbakke@fastmail.com>2019-05-21 17:25:54 +0200
commit7ef08efa21900e6e43415b9f9db0e51a04e17fa5 (patch)
treeae714dd5e09985a7feeb822f702a8df995e628f8 /gnu/packages/gnome.scm
parent8308f0ba9e65daeadcc7e8922377b3d5e9f10e05 (diff)
downloadguix-patches-7ef08efa21900e6e43415b9f9db0e51a04e17fa5.tar
guix-patches-7ef08efa21900e6e43415b9f9db0e51a04e17fa5.tar.gz
gnu: libnotify: Propagate required inputs.
libnotify doesn't propagate other needed libraries for linking against it resulting in pkg-config errors like > Package gdk-pixbuf-2.0 was not found in the pkg-config search path. > Perhaps you should add the directory containing `gdk-pixbuf-2.0.pc' > to the PKG_CONFIG_PATH environment variable * gnu/packages/gnome.scm (libnotify)[inputs]: Move GLIB and GDK-PIXBUF ... [propagated-inputs]: ... here. New field. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9671c21a9d..8f23935ff6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1108,10 +1108,12 @@ configuring CUPS.")
(base32
"017wgq9n00hx39n0hm784zn18hl721hbaijda868cm96bcqwxd4w"))))
(build-system gnu-build-system)
+ (propagated-inputs
+ `(;; In Requires of libnotify.pc.
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("glib" ,glib)))
(inputs
- `(("gdk-pixbuf" ,gdk-pixbuf)
- ("glib" ,glib)
- ("gtk+" ,gtk+)
+ `(("gtk+" ,gtk+)
("libpng" ,libpng)))
(native-inputs
`(("pkg-config" ,pkg-config)