summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-06 18:54:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:44:24 +0100
commit59dac02602a05e909e6bd48a9e795b60d3be8836 (patch)
treee462d89b11aba2b68c10b35584567cd132b7c8e9 /gnu/packages/gnome.scm
parentcaf6c3637bc418e482ab561ef219d45b4c3616e3 (diff)
downloadguix-patches-59dac02602a05e909e6bd48a9e795b60d3be8836.tar
guix-patches-59dac02602a05e909e6bd48a9e795b60d3be8836.tar.gz
gnu: gnome-control-center: Update to 3.28.2.
* gnu/packages/gnome.scm (gnome-control-center): Update to 3.28.2. [build-system]: Use meson-build-system. [arguments]: Add configure flags. [native-inputs]: Add gkt+:bin.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3f43e29d46..fe9f0c27a2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5666,7 +5666,7 @@ devices using the GNOME desktop.")
(define-public gnome-control-center
(package
(name "gnome-control-center")
- (version "3.24.3")
+ (version "3.28.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5674,10 +5674,13 @@ devices using the GNOME desktop.")
name "-" version ".tar.xz"))
(sha256
(base32
- "18ncjqjj93a39sla2zjr9i6pw59yh87p4jla899lmvi2qajd5923"))))
- (build-system glib-or-gtk-build-system)
+ "0d6pjdbsra16nav8201kaadja5yma92bhziki9601ilk2ry3v7pz"))))
+ (build-system meson-build-system)
(arguments
- '(#:phases
+ '(#:glib-or-gtk? #t
+ #:configure-flags
+ (list "-Dcheese=false")
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -5692,6 +5695,7 @@ devices using the GNOME desktop.")
#t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("xsltproc" ,libxslt)))