summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-21 07:20:47 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:53:52 +0200
commit30003a64d142e9c269d97c78e21e673e95d8d141 (patch)
tree92ce0336994e6df41baf6c674418be45f9e205b1 /gnu/packages/gnome.scm
parent2e6bc59539228224a8909ebd9c0fb18280d36201 (diff)
downloadguix-patches-30003a64d142e9c269d97c78e21e673e95d8d141.tar
guix-patches-30003a64d142e9c269d97c78e21e673e95d8d141.tar.gz
gnu: Add tepl.
* gnu/packages/gnome.scm (tepl): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5281193406..fc63341bcb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -259,6 +259,39 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public tepl
+ (package
+ (name "tepl")
+ (version "4.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0mm2z849hnni7597an05mrv0dckrxjngpf2xfa0g5s17i8x6gxp6"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:tests? #f)) ; FIX-ME: Requires gvfs
+ (native-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("amtk" ,amtk)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gtksourceview" ,gtksourceview)
+ ("libxml2" ,libxml2)
+ ("uchardet" ,uchardet)))
+ (synopsis "Text editor product line")
+ (description "Tepl is a library that eases the development of
+GtkSourceView-based text editors and IDEs.")
+ (home-page "https://wiki.gnome.org/Projects/Tepl")
+ (license license:lgpl2.1+)))
+
(define-public krb5-auth-dialog
(package
(name "krb5-auth-dialog")