summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-22 14:50:21 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:54:02 +0200
commit1aefe650075b050a0e79dffcd6fdba140323d220 (patch)
treebf2272a81716ba053e70a958be4b14858f204756 /gnu/packages/gnome.scm
parent72e20842c6ae899d22ff294d9a4f0ca34d71be61 (diff)
downloadguix-patches-1aefe650075b050a0e79dffcd6fdba140323d220.tar
guix-patches-1aefe650075b050a0e79dffcd6fdba140323d220.tar.gz
gnu: Add gnome-music.
* gnu/packages/gnome.scm (gnome-music): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 34801a054c..e83004fb08 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -260,6 +260,68 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-music
+ (package
+ (name "gnome-music")
+ (version "3.34.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1r5sfw5cbd6qqh27lzhblazir0bfi3k7nqppw66qw990isqm5psy"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-gnome-music
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let*
+ ((out (assoc-ref outputs "out"))
+ (pylib (string-append out "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program (string-append out "/bin/gnome-music")
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))
+ `("GST_PLUGIN_SYSTEM_PATH" = (,(getenv "GST_PLUGIN_SYSTEM_PATH")))
+ `("GRL_PLUGIN_PATH" = (,(getenv "GRL_PLUGIN_PATH")))
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))))
+ #t)))))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("itstools" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+ ("grilo" ,grilo)
+ ("grilo-plugins" ,grilo-plugins)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gstreamer" ,gstreamer)
+ ("gvfs" ,gvfs)
+ ("libdazzle" ,libdazzle)
+ ("libmediaart" ,libmediaart)
+ ("libsoup" ,libsoup)
+ ("pycairo" ,python-pycairo)
+ ("pygobject" ,python-pygobject)
+ ("tracker" ,tracker)
+ ("tracker-miners" ,tracker-miners)))
+ (synopsis "Simple music player for GNOME desktop")
+ (description "GNOME Music is the new GNOME music playing application that
+aims to combine an elegant and immersive browsing experience with simple
+and straightforward controls.")
+ (home-page "https://wiki.gnome.org/Apps/Music")
+ (license license:gpl2+)))
+
(define-public portablexdr
(package
(name "portablexdr")