summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-06 15:41:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:42:29 +0100
commit8c0fab36d82bf6c82f54cc20dd53de75b25d2b56 (patch)
tree84ea089f502f20ca947db9bef482360de2187073 /gnu/packages/gnome.scm
parentd953418aee38b656b0b8cd11f440d936e45d6b82 (diff)
downloadguix-patches-8c0fab36d82bf6c82f54cc20dd53de75b25d2b56.tar
guix-patches-8c0fab36d82bf6c82f54cc20dd53de75b25d2b56.tar.gz
gnu: gnome-mines: Update to 3.28.0.
* gnu/packages/gnome.scm (gnome-mines): Update to 3.28.0. [build-system]: Use meson-build-system. [arguments]: Delete "bootstrap" phase; remove "patch-/bin/true" phase. [native-inputs]: Add glib:bin, vala, yeld, and appstream-glib; remove libxml2.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d27a52a7dc..6ddc07667d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2797,7 +2797,7 @@ and other secrets. It communicates with the \"Secret Service\" using DBus.")
(define-public gnome-mines
(package
(name "gnome-mines")
- (version "3.26.0")
+ (version "3.28.0")
(source
(origin
(method url-fetch)
@@ -2806,21 +2806,21 @@ and other secrets. It communicates with the \"Secret Service\" using DBus.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1sfxdvns8nppdagnhpd9vd7n77sk5rdji3kdqnc78c2p1npiw11b"))))
- (build-system glib-or-gtk-build-system)
+ "16w55hqaxipcv870n9gpn6qiywbqbyg7bjshaa02r75ias8dfxvf"))))
+ (build-system meson-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'patch-/bin/true
- (lambda _
- (substitute* "configure"
- (("/bin/true") (which "true"))))))))
+ (delete 'bootstrap))))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("pkg-config" ,pkg-config)
("desktop-file-utils" ,desktop-file-utils)
("intltool" ,intltool)
("itstool" ,itstool)
- ("xmllint" ,libxml2)))
+ ("vala" ,vala)
+ ("yelp" ,yelp)
+ ("appstream-glib" ,appstream-glib)))
(inputs
`(("gtk+" ,gtk+)
("libgnome-games-support" ,libgnome-games-support)