summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-22 23:16:47 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-22 23:50:55 +0100
commit98eca86435147ffa53314614a1c2a5df1929192c (patch)
tree1e090d5ba9e5cd62eb1bf0af8f2ea658ad9e26b9 /gnu/packages/gnome.scm
parentf12cf46eed08c5e8cc6ffec7316ea2de262aa607 (diff)
downloadguix-patches-98eca86435147ffa53314614a1c2a5df1929192c.tar
guix-patches-98eca86435147ffa53314614a1c2a5df1929192c.tar.gz
gnu: gupnp-igd: Set HOME before 'check' phase.
* gnu/packages/gnome.scm (gupnp-igd)[arguments]: Add 'set-home' phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 82b002bd0d..9a31e3a087 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -257,6 +257,11 @@
(string-append (assoc-ref inputs "docbook-xml-4.1.2")
"/xml/dtd/docbook/"))))
#t))
+ (add-before 'check 'set-home
+ (lambda _
+ ;; A test using GIO expects ~/.config/glib-2.0/settings to be
+ ;; writable.
+ (setenv "HOME" (getcwd))))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))