summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-04 22:24:22 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-04 22:39:47 +0100
commit3ee142ebd6688724586ad006be50d309ec4da144 (patch)
tree01da5e79575bb4857687f54fc16324b82b1f1e4e /gnu/packages/gnome.scm
parent73f78d556bea99361bb93683b0ced9c714e9c69f (diff)
downloadguix-patches-3ee142ebd6688724586ad006be50d309ec4da144.tar
guix-patches-3ee142ebd6688724586ad006be50d309ec4da144.tar.gz
gnu: libhandy: Skip test that requires librsvg on non-x86_64.
* gnu/packages/gnome.scm (libhandy)[arguments]: Add 'skip-test-that-requires-svg' phase on non-x86_64.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7df7f18874..3e607dc7df 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11476,6 +11476,14 @@ tabs, and it supports drag and drop re-ordering of terminals.")
(search-input-file inputs
"/xml/dtd/docbook/docbookx.dtd"))))
(find-files "doc" "\\.xml"))))
+ ,@(if (target-x86-64?)
+ '()
+ '((add-after 'unpack 'skip-test-that-requires-svg
+ (lambda _
+ ;; On non-x86-64, gdk-pixbuf lacks librsvg support, so
+ ;; skip the test that requires it.
+ (substitute* "tests/meson.build"
+ (("'test-avatar',") ""))))))
(add-before 'check 'pre-check
(lambda _
;; Tests require a running X server.