summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorDaniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>2022-01-10 16:37:15 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-01-11 15:45:51 +0100
commit0957f20cb7b831893ad18b4b3b36670ecaf979d3 (patch)
treee04947b67b4a39d13c64b3a06643f8826c39a2da /gnu/packages/gnome.scm
parente92afc59048502a4a23ea5866522ba5f3ccc8aba (diff)
downloadguix-patches-0957f20cb7b831893ad18b4b3b36670ecaf979d3.tar
guix-patches-0957f20cb7b831893ad18b4b3b36670ecaf979d3.tar.gz
gnu: eog: Fix build with libportal-0.5.
After the update to libportal-0.5 in 294476022f19139e290acb448d4575de0f851673 eog fails with: ../eog-40.3/src/eog-util.c:48:10: fatal error: libportal/portal-gtk3.h: No such file or directory This was already fixed upstream and this commits extracts the patch. * gnu/packages/patches/eog-update-libportal-usage.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gnome.scm(eog)[origin]: Add new patch. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index facbeb3b20..4a3fd99312 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
+;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6427,7 +6428,9 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0ddjwcd77nw0rxb5x5bz5hd671m8gya9827p8rsnb58x103kpai8"))))
+ "0ddjwcd77nw0rxb5x5bz5hd671m8gya9827p8rsnb58x103kpai8"))
+ ;; XXX: Remove when upgrading to 42.0
+ (patches (search-patches "eog-update-libportal-usage.patch"))))
(build-system meson-build-system)
(arguments
`(#:meson ,meson-0.59 ;positional arguments error with meson 0.60