summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-11-19 23:19:40 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-21 09:08:51 -0500
commit404c7eedfe73673af8f590315fb85f5a725461b3 (patch)
treec941758c1557b772282050b2646308d74205cce2 /gnu/packages/gnome.scm
parent72501a555eaad267dc68c88c5f22de1a1573e371 (diff)
downloadguix-patches-404c7eedfe73673af8f590315fb85f5a725461b3.tar
guix-patches-404c7eedfe73673af8f590315fb85f5a725461b3.tar.gz
gnu: gnome-session: Restore elogind support.
* gnu/packages/patches/gnome-session-support-elogind.patch: New file. * gnu/local.mk: Add it. * gnu/packages/gnome.scm (gnome-session)[source]: Use it. [arguments]: Add "-Delogind=true" to #:configure-flags; remove phases that patch in old-style elogind support. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ebe718ab4a..63e9d4ac73 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7252,6 +7252,7 @@ such as gzip tarballs.")
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major version) "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "gnome-session-support-elogind.patch"))
(sha256
(base32
"02z0xr6sv9ibl7awbw9j4y05hf4jk1zgvsbbmh7n27hhjvsvc8pl"))))
@@ -7260,18 +7261,6 @@ such as gzip tarballs.")
#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'pre-configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Use elogind instead of systemd.
- (substitute* "meson.build"
- (("libsystemd-login") "libelogind")
- (("and libsystemd_daemon_dep.found.*") ","))
- (substitute* "gnome-session/gsm-systemd.c"
- (("#include <systemd/sd-login.h>")
- "#include <elogind/sd-login.h>"))
- ;; Remove uses of the systemd daemon.
- (substitute* "gnome-session/gsm-autostart-app.c"
- (("#ifdef HAVE_SYSTEMD") "#if 0"))))
(add-after 'install 'wrap-gnome-session
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure 'gnome-session' finds the 'gsettings' program.
@@ -7283,6 +7272,7 @@ such as gzip tarballs.")
#:configure-flags
'("-Ddocbook=false" ; FIXME: disabled because of docbook validation error
"-Dman=false" ; FIXME: disabled because of docbook validation error
+ "-Delogind=true"
"-Dsystemd=false"
"-Dsystemd_session=disable"
"-Dsystemd_journal=false")))