summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-09-11 23:26:20 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-09 21:54:16 +0200
commitd6462be6a83bf33b569980734fb7ee23836c91a0 (patch)
tree4ce876c2cc044352a985f0cc5dde48e38cab8781 /gnu/packages/gnome.scm
parent3066ad29cc0f163f7faaf38d1e459e9737ac1355 (diff)
downloadguix-patches-d6462be6a83bf33b569980734fb7ee23836c91a0.tar
guix-patches-d6462be6a83bf33b569980734fb7ee23836c91a0.tar.gz
gnu: gnome-control-center: Update to 44.3.
Some previous fixes have been merged upstream. The gnome version is now read from a dbus service, and passwd is already searched in /run/setuid-programs. In order to let the tests run, we use the same tests environment as gnome-shell. * gnu/packages/gnome.scm (gnome-control-center): Update to 44.3. Apply gnome-control-center-firmware-security.patch. [#:phases]<patch-paths>: Adjust accordingly. <skip-gtk-update-icon-cache>: Adjust accordingly. <check>: Override the check phase to run under dbus. [native-inputs]: Add setxkbmap. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm43
1 files changed, 30 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index eaceb76e1e..4ed22d4da0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9032,7 +9032,7 @@ devices using the GNOME desktop.")
(define-public gnome-control-center
(package
(name "gnome-control-center")
- (version "42.4")
+ (version "44.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -9040,7 +9040,10 @@ devices using the GNOME desktop.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1ln5rch6zbfh3vl2nnnmw39bylgg38rin6xp7ra0ra4ay3wv3gvs"))))
+ "0yhcm0c0ghkfqswqlkwcln3jpaz6jzvqaph2c3lgmv635w2nash6"))
+ (patches
+ (search-patches
+ "gnome-control-center-firmware-security.patch"))))
(build-system meson-build-system)
(arguments
(list
@@ -9064,19 +9067,32 @@ devices using the GNOME desktop.")
"panels/network/connection-editor/net-connection-editor.c")
(("\"nm-connection-editor")
(string-append "\"" (search-input-file
- inputs "bin/nm-connection-editor"))))
- (substitute* "panels/user-accounts/run-passwd.c"
- (("/usr/bin/passwd")
- "/run/setuid-programs/passwd"))
- (substitute* "panels/info-overview/cc-info-overview-panel.c"
- (("DATADIR \"/gnome/gnome-version.xml\"")
- (format #f "~s" (search-input-file
- inputs "share/gnome/gnome-version.xml"))))))
+ inputs "bin/nm-connection-editor"))))))
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "build-aux/meson/meson_post_install.py"
- (("gtk-update-icon-cache") (which "true"))))))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
+ (replace 'check
+ (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
+ (when tests?
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ ;; For the missing /var/lib/dbus/machine-id
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (setenv "NO_AT_BRIDGE" "1")
+ (setenv "HOME" "/tmp")
+ (setenv "XDG_RUNTIME_DIR" (string-append (getcwd) "/runtime-dir"))
+ (mkdir (getenv "XDG_RUNTIME_DIR"))
+ (chmod (getenv "XDG_RUNTIME_DIR") #o700)
+ (setenv "MESON_TESTTHREADS"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (invoke "dbus-run-session" "--"
+ "meson" "test" "-t" "0")))))))
(native-inputs
(list docbook-xsl
gettext-minimal
@@ -9085,7 +9101,8 @@ devices using the GNOME desktop.")
pkg-config
python
python-dbusmock
- xorg-server-for-tests))
+ xorg-server-for-tests
+ setxkbmap))
(inputs
(list accountsservice
colord-gtk