summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-09-19 13:32:46 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-10 21:59:25 +0200
commitb701a7018d94aebef6a967ec235c72c1f7cdfe5c (patch)
tree45caa27584d50a6f58e1906a7ec0c90382d9acdb /gnu/packages/gnome.scm
parentee554a35e012ecefc9e9e2267e1387b3bf1ca5a5 (diff)
downloadguix-patches-b701a7018d94aebef6a967ec235c72c1f7cdfe5c.tar
guix-patches-b701a7018d94aebef6a967ec235c72c1f7cdfe5c.tar.gz
gnu: upower: Update to 1.90.2.
Upower has an extra hardware description file for use with udev. It should be installed under upower’s output, not eudev’s. A test is disabled, for calling an unimplemented bluez method. The conditional 'adjust-test-for-excess-precision phase is included in the new 'adjust-test-suite, so that the list of phases is always the same. * gnu/packages/gnome.scm (upower): Update to 1.90.2. [#:configure-flags]: Set udevhwdbdir. [#:phases] <adjust-test-for-excess-precision>: Add this phase unconditionnally <disable-failing-test>: Disable test_bluetooth_hidpp_mouse. [inputs]: Remove dbus-glib. [native-inputs]: Add dbus.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 23 insertions, 16 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d8cdd11bd4..6e3933ec96 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5727,7 +5727,7 @@ faster results and to avoid unnecessary server load.")
(define-public upower
(package
(name "upower")
- (version "1.90.0")
+ (version "1.90.2")
(source
(origin
(method git-fetch)
@@ -5736,7 +5736,7 @@ faster results and to avoid unnecessary server load.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1g17rm91p8vfpjyb0k2shylrs55nccn3fa890vlk4n9s71sghbzq"))
+ (base32 "13xp423ycv8imf2cmgf6lii9f01p7x2v19cny7acrmczkc0cqv7d"))
(modules '((guix build utils)))
(snippet
;; Upstream commit <https://cgit.freedesktop.org/upower/commit/
@@ -5759,19 +5759,25 @@ faster results and to avoid unnecessary server load.")
;; If not specified, udev will try putting history information
;; in /gnu/store.
"-Dhistorydir=/var/lib/upower"
- (string-append "-Dudevrulesdir=" #$output "/bin/udev/rules.d"))
- #:phases (if (target-x86-32?)
- #~(modify-phases %standard-phases
- (add-after 'unpack 'adjust-test-for-excess-precision
- (lambda _
- ;; Address test failure caused by excess precision
- ;; on i686:
- ;; <https://gitlab.freedesktop.org/upower/upower/-/issues/214>.
- (substitute* "src/linux/integration-test.py"
- (("assertEqual(.*)40\\.0" _ middle)
- (string-append
- "assertAlmostEqual" middle "40.0"))))))
- #~%standard-phases)))
+ (string-append "-Dudevrulesdir=" #$output "/bin/udev/rules.d")
+ (string-append "-Dudevhwdbdir=" #$output "/lib/udev/hwdb.d"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'adjust-test-suite
+ (lambda _
+ ;; This test calls an unimplemented bluez dbus method.
+ (substitute* "src/linux/integration-test.py"
+ (("test_bluetooth_hidpp_mouse")
+ "disabled_test_bluetooth_hidpp_mouse"))
+ #$@(if (target-x86-32?)
+ ;; Address test failure caused by excess precision
+ ;; on i686:
+ ;; <https://gitlab.freedesktop.org/upower/upower/-/issues/214>.
+ '((substitute* "src/linux/integration-test.py"
+ (("assertEqual(.*)40\\.0" _ middle)
+ (string-append
+ "assertAlmostEqual" middle "40.0"))))
+ '()))))))
(native-inputs
(list `(,glib "bin") ; for gdbus-codegen
gobject-introspection
@@ -5785,12 +5791,13 @@ faster results and to avoid unnecessary server load.")
python-packaging
python-pygobject
umockdev
+ dbus
;; For man pages.
docbook-xsl
libxslt ; for 'xsltproc'
libxml2)) ; for 'XML_CATALOG_FILES'
(inputs
- (list dbus-glib libgudev libusb))
+ (list libgudev libusb))
(propagated-inputs
;; In Requires of upower-glib.pc.
(list glib))