summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-11-14 17:08:02 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-17 20:30:14 +0100
commit030474e3f95e8f3a37f75916efc501c569618841 (patch)
tree956c10708f4379d23af766744b2a5ab2b4fb255c /gnu/packages/gnome.scm
parentd22cca3a6e38459a7186d9138acf7c2cebabbd69 (diff)
downloadguix-patches-030474e3f95e8f3a37f75916efc501c569618841.tar
guix-patches-030474e3f95e8f3a37f75916efc501c569618841.tar.gz
gnu: orca: Update to 44.2.
* gnu/packages/gnome.scm (orca): Update to 44.2. [#:phases]<qualify-programs>: Also expand pgrep. [inputs]: Add procps. Replace at-spi2-atk with at-spi2-core. Change-Id: I05fdab970909edda44ca9957d2ad721f62e6bfec Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8b5af85d45..a406eec09d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11089,7 +11089,7 @@ accessibility infrastructure.")
(define-public orca
(package
(name "orca")
- (version "42.3")
+ (version "44.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -11098,17 +11098,25 @@ accessibility infrastructure.")
name "-" version ".tar.xz"))
(sha256
(base32
- "097pyav3z5ssic8vwd7v1s7vynpycdpyfr324rr6c7mfzq5vmp7s"))))
+ "11jn925ga970y74did96ms78pc3lshkd9rd8v82i6zdzigxa7yvd"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'qualify-xkbcomp
+ (add-before 'configure 'qualify-programs
(lambda* (#:key inputs #:allow-other-keys)
(let ((xkbcomp (string-append
- (assoc-ref inputs "xkbcomp") "/bin/xkbcomp")))
+ (assoc-ref inputs "xkbcomp") "/bin/xkbcomp"))
+ (pgrep (string-append
+ (assoc-ref inputs "procps") "/bin/pgrep")))
(substitute* "src/orca/orca.py"
- (("'xkbcomp'") (format #f "'~a'" xkbcomp))))))
+ (("'xkbcomp'") (format #f "'~a'" xkbcomp)))
+ (substitute* "src/orca/debug.py"
+ (("'pgrep %s'")
+ (format #f "'~a %s'" pgrep)))
+ (substitute* "src/orca/orca_bin.py.in"
+ (("'pgrep -u %s -x orca'")
+ (format #f "'~a -u %s -x orca'" pgrep))))))
(add-after 'install 'wrap-orca
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/orca")
@@ -11124,13 +11132,14 @@ accessibility infrastructure.")
pkg-config
libxml2))
(inputs
- (list at-spi2-atk
+ (list at-spi2-core
bash-minimal
gsettings-desktop-schemas
gstreamer
gst-plugins-base
gst-plugins-good
gtk+
+ procps ; for pgrep
python
python-pygobject
python-pyatspi