summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-17 23:26:28 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-04 21:29:13 +0100
commite1d944d122c2a763f715c39b6c84fa6bc5e371ca (patch)
tree53505117e0c11d68c97f1a9318719a508d2cb226 /gnu/packages/gnome-xyz.scm
parenta10ad22d7a1de1d06d578c6cfad6381fb5ec47a3 (diff)
downloadguix-patches-e1d944d122c2a763f715c39b6c84fa6bc5e371ca.tar
guix-patches-e1d944d122c2a763f715c39b6c84fa6bc5e371ca.tar.gz
gnu: Remove gnome-shell-extension-jiggle.
This extension has not been made compatible with GNOME 44. * gnu/packages/gnome-xyz.scm (gnome-shell-extension-jiggle): Remove variable. Change-Id: I9afa9c2fe110ba883524eb9ca9acab42fbdd8f00
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm42
1 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index d369e92c23..7a672c507b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1109,48 +1109,6 @@ shell, including panels, corners, workspaces.")
(deprecated-package "gnome-shell-extension-vertical-overview"
gnome-shell-extension-v-shell))
-(define-public gnome-shell-extension-jiggle
- (package
- (name "gnome-shell-extension-jiggle")
- (version "8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jeffchannell/jiggle/")
- (commit version)))
- (sha256
- (base32
- "1wbdx2bp22bdwj51ckgivwglkmckr7z8kfwvc8nv4y376hjz5jxz"))
- (file-name (git-file-name name version))
- (snippet
- '(begin (delete-file "schemas/gschemas.compiled")))))
- (build-system copy-build-system)
- (arguments
- `(#:install-plan
- '(("." ,(string-append
- "share/gnome-shell/extensions/"
- "jiggle@jeffchannell.com")
- #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
- "\\.xml$" "\\.compiled$")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-version
- (lambda _
- (substitute* "metadata.json"
- (("\"40.0\"") "\"40\", \"41\""))))
- (add-before 'install 'compile-schemas
- (lambda _
- (with-directory-excursion "schemas"
- (invoke "glib-compile-schemas" ".")))))))
- (native-inputs
- (list `(,glib "bin"))) ; for glib-compile-resources
- (home-page "https://github.com/jeffchannell/jiggle")
- (synopsis "Mouse cursor enlargement for small and fast movements")
- (description "Jiggle is a Gnome Shell extension that highlights the cursor
-position when the mouse is moved rapidly.")
- (license license:gpl2)))
-
(define-public gnome-shell-extension-burn-my-windows
(package
(name "gnome-shell-extension-burn-my-windows")