summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-17 17:20:41 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-20 00:38:01 +0100
commit8f4f7bd654f22b601e402f4d51a7f076b72f7993 (patch)
tree8abbf147381dfa5ca4ea1eb17eba7bf77be18304 /gnu/packages/gnome-xyz.scm
parent72b1f2d33522e6ef681a3d3ef1a370a9f415e989 (diff)
downloadguix-patches-8f4f7bd654f22b601e402f4d51a7f076b72f7993.tar
guix-patches-8f4f7bd654f22b601e402f4d51a7f076b72f7993.tar.gz
gnu: Deprecate gnome-shell-extension-hide-app-icon.
This extension does not work with GNOME 44, and has not received any work. However, Just Perfection seems to have an option to hide application icons. * gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon): Deprecate in favor of gnome-shell-extension-just-perfection. Change-Id: I6af14b6c9e1db7176d9be6bec2b90f77e7db36c1 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm52
1 files changed, 4 insertions, 48 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 8501654419..460f11db90 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -855,54 +855,6 @@ notifications or files, and other features like SMS messaging and remote
control.")
(license license:gpl2)))
-(define-public gnome-shell-extension-hide-app-icon
- (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
- (revision "0"))
- (package
- (name "gnome-shell-extension-hide-app-icon")
- (version (git-version "2.7" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append "https://github.com/michael-rapp"
- "/gnome-shell-extension-hide-app-icon.git"))
- (commit commit)))
- (sha256
- (base32
- "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; no test target
- #:make-flags (list (string-append "EXTENSIONS_DIR="
- (assoc-ref %outputs "out")
- "/share/gnome-shell/extensions"))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (pre "/share/gnome-shell/extensions/")
- (dir "hide-app-icon@mrapp.sourceforge.com"))
- (copy-recursively dir (string-append out pre dir))
- #t))))))
- (native-inputs
- (list `(,glib "bin") intltool))
- (propagated-inputs
- (list glib))
- (synopsis "Hide app icon from GNOME's panel")
- (description "This extension hides the icon and/or title of the
-currently focused application in the top panel of the GNOME shell.")
- (home-page
- "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
- (license
- ;; README.md and LICENSE.txt disagree -- the former claims v3, the
- ;; latter v2. No mention of "or later" in either place or in the code.
- (list license:gpl2
- license:gpl3)))))
-
(define-public gnome-shell-extension-just-perfection
(package
(name "gnome-shell-extension-just-perfection")
@@ -955,6 +907,10 @@ GNOME Shell itself does not provide out of the box, such as the ability to hide
certain elements or change animation speeds.")
(license license:gpl3)))
+(define-public gnome-shell-extension-hide-app-icon
+ (deprecated-package "gnome-shell-extension-hide-app-icon"
+ gnome-shell-extension-just-perfection))
+
(define-public gnome-shell-extension-dash-to-panel
(package
(name "gnome-shell-extension-dash-to-panel")