summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-18 19:19:26 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-20 00:38:12 +0100
commit49897f2dde7f469c83c496fad2699d3a05f72701 (patch)
treea0442f59072580af1aaf05802bb476ea5a7aaad3 /gnu/packages/gnome-xyz.scm
parent1f9339fce4a81757fb18372aa974217d8e03c551 (diff)
downloadguix-patches-49897f2dde7f469c83c496fad2699d3a05f72701.tar
guix-patches-49897f2dde7f469c83c496fad2699d3a05f72701.tar.gz
gnu: Deprecate gnome-shell-extension-vertical-overview.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-vertical-overview): Replace with gnome-shell-extension-v-shell. Change-Id: I1c6539fd6532046f8445ee33b286645b9e68a053 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm39
1 files changed, 2 insertions, 37 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index cf5d55f150..b6c1f6d3cb 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1136,43 +1136,8 @@ shell, including panels, corners, workspaces.")
(license license:gpl3)))
(define-public gnome-shell-extension-vertical-overview
- (package
- (name "gnome-shell-extension-vertical-overview")
- (version "10")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/RensAlthuis/vertical-overview")
- (commit (string-append "v" version))))
- (sha256
- (base32
- "1sqkbg93qqrq47wyfnh2flg7dpsmv5c2pmkx8kgqhnbl7j2kgi0l"))
- (file-name (git-file-name name version))
- (snippet
- '(begin (delete-file "schemas/gschemas.compiled")))))
- (build-system copy-build-system)
- (arguments
- `(#:install-plan
- '(("." ,(string-append
- "share/gnome-shell/extensions/"
- "vertical-overview@RensAlthuis.github.com")
- #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
- "\\.xml$" "\\.compiled$")))
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'compile-schemas
- (lambda _
- (with-directory-excursion "schemas"
- (invoke "glib-compile-schemas" ".")))))))
- (native-inputs
- (list `(,glib "bin"))) ; for glib-compile-resources
- (home-page "https://github.com/RensAlthuis/vertical-overview")
- (synopsis "Provides a vertical overview in Gnome 40 and upper")
- (description "This Gnome extension replaces the new horizontally oriented
-Gnome overview with something that resembles the old vertically oriented
-style.")
- (license license:gpl3)))
+ (deprecated-package "gnome-shell-extension-vertical-overview"
+ gnome-shell-extension-v-shell))
(define-public gnome-shell-extension-jiggle
(package