summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-09 21:21:29 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-09 21:21:29 +0200
commit24fee2615ce7a18a7fcd6054b73375a890556cf3 (patch)
tree353f9e87b8ec736f32eed840c58dc7d5651c19cf /gnu/packages/gnome-xyz.scm
parent7d134b57b79188f8c878625d4e09f9bd6181e8c0 (diff)
parent7937c8827b8d23347a3159b4696335bd19fc17aa (diff)
downloadguix-patches-24fee2615ce7a18a7fcd6054b73375a890556cf3.tar
guix-patches-24fee2615ce7a18a7fcd6054b73375a890556cf3.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 86dacdf7ff..100018a2dc 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1050,6 +1050,29 @@ scrollable tiling of windows and per monitor workspaces. It's inspired by paper
notebooks and tiling window managers.")
(license license:gpl3)))
+(define-public gnome-shell-extension-night-theme-switcher
+ (package
+ (name "gnome-shell-extension-night-theme-switcher")
+ (version "65")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://gitlab.com/rmnvgr/nightthemeswitcher-gnome-shell-extension")
+ (commit version)))
+ (sha256
+ (base32 "0qhi2g2lh6m8vhrmmfi60977f0i4k9x1zj68lrvpzzlqndz8cgh9"))
+ (file-name (git-file-name name version))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config (list glib "bin")))
+ (synopsis "Automatic theme switcher for GNOME Shell")
+ (description
+ "Automatically toggle your GNOME desktop's color scheme between light and
+dark, switch backgrounds and run custom commands at sunset and sunrise.")
+ (home-page "https://nightthemeswitcher.romainvigier.fr")
+ (license license:gpl2+)))
+
(define-public gpaste
(package
(name "gpaste")