summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-10-27 19:44:52 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-29 08:32:45 +0100
commitb125b9deee25940aaf743f984875c033b1fe380a (patch)
tree176cc251e7af366ab990af85ce92c7147ce7b560 /gnu/packages/glib.scm
parent54eb6d6e8ad2955bd84bb6502a241c2c4878dcdd (diff)
downloadguix-patches-b125b9deee25940aaf743f984875c033b1fe380a.tar
guix-patches-b125b9deee25940aaf743f984875c033b1fe380a.tar.gz
gnu: python-pygobject: Update style.
* gnu/packages/glib.scm (python-pygobject) [source]<sha256>: Reindent. <snippet>: Convert to G-Expression. Remove trailing #f. [arguments]: Convert to list of G-Expressions. [native-inputs]: Drop labels. Change-Id: I325de196b79cbdd0acaed3c40be42aa7335abcae Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 2c813fd594..1012d2190b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1015,33 +1015,31 @@ useful for C++.")
(version-major+minor version)
"/pygobject-" version ".tar.xz"))
(sha256
- (base32
- "1z6aagb46fhhdd0bb3zk6dfdw3s4y2fva0vv3jpwjj6mvar0hq22"))
+ (base32 "1z6aagb46fhhdd0bb3zk6dfdw3s4y2fva0vv3jpwjj6mvar0hq22"))
(modules '((guix build utils)))
(snippet
- '(begin
- ;; We disable these tests in a snippet so that they are inherited
- ;; by the Python 2 variant which is built differently.
- (with-directory-excursion "tests"
- ;; FIXME: These tests require Gdk and/or Gtk 4.
- (for-each delete-file
- '("test_atoms.py" "test_overrides_gtk.py"
- "test_overrides_gdk.py"))
- #t)))))
+ ;; We disable these tests in a snippet so that they are inherited
+ ;; by the Python 2 variant which is built differently.
+ #~(with-directory-excursion "tests"
+ ;; FIXME: These tests require Gdk and/or Gtk 4.
+ (for-each delete-file
+ '("test_atoms.py" "test_overrides_gtk.py"
+ "test_overrides_gdk.py"))))))
(build-system meson-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; The default 90 seconds can be too low on slower machines.
- (invoke "meson" "test" "--timeout-multiplier" "5")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The default 90 seconds can be too low on slower machines.
+ (invoke "meson" "test" "--timeout-multiplier" "5")))))))
(native-inputs
- `(("glib-bin" ,glib "bin")
- ("pkg-config" ,pkg-config)
- ("python-pytest" ,python-pytest)
- ("python-wrapper" ,python-wrapper))) ; For patching shebangs
+ (list `(,glib "bin")
+ pkg-config
+ python-pytest
+ python-wrapper)) ; For patching shebangs
(inputs
(list python python-pycairo gobject-introspection))
(propagated-inputs