summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-03-22 21:30:50 +0100
committerChristopher Baines <mail@cbaines.net>2024-03-24 10:12:50 +0000
commit37db4e218845472d3c6f7759397921c969400603 (patch)
treecaa36c98c35b10ff7a09a9181dbc1e4fa11393ae /gnu/packages/glib.scm
parent88c180402258a13ca605ebd1073c471c8672a539 (diff)
downloadguix-patches-37db4e218845472d3c6f7759397921c969400603.tar
guix-patches-37db4e218845472d3c6f7759397921c969400603.tar.gz
gnu: Add dbus-1.15.0.
The NEWS file for 1.15.2 (the next release after 1.15.0) indicates a breaking change. This is the latest release that the lightdm testsuite can work with. * gnu/packages/glib.scm (dbus-1.15.0): New variable. Change-Id: I9c3553b315e6618fbbf19aade6b807ab7120364b Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index bff8bec81f..cf066a8aa6 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -209,6 +209,21 @@ shared NFS home directories.")
(("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-local.conf")
"/var/run/jami/session-local.conf")))))))))))
+(define-public dbus-1.15.0
+ ;; Dbus 1.15.2 has a breaking change.
+ (hidden-package
+ (package/inherit dbus
+ (version "1.15.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://dbus.freedesktop.org/releases/dbus/dbus-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "02k4zm5h24clwp4csp2r3xp2lxib31jlk3xkgdj2c0njkb5whwsh"))
+ (patches (search-patches "dbus-helper-search-path.patch")))))))
+
;;; The reason this is not enabled in the regular dbus package is because it
;;; impacts the performance of D-Bus (including its library) as a whole, even
;;; when the DBUS_VERBOSE environment variable is not set.