summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-07 20:42:02 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-07 20:42:03 +0200
commit20e3f3e1151b2f22ae7fb5aa8764148654f35090 (patch)
tree3f6af3a73f4548b8f6564a31984abeeefd60b0ef /gnu/packages/glib.scm
parent965e2d6eb90826181471b834437ac68dcb9217cb (diff)
parent451ba2e5bb523c18a2ccc941df47b598c48ef57e (diff)
downloadguix-patches-20e3f3e1151b2f22ae7fb5aa8764148654f35090.tar
guix-patches-20e3f3e1151b2f22ae7fb5aa8764148654f35090.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm44
1 files changed, 28 insertions, 16 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index c65cfb2022..4a5f8ebfb2 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
@@ -1203,26 +1204,37 @@ programming language. It also provides the @command{dbusxx-xml2cpp} and
(define-public dbus-cxx
(package
(name "dbus-cxx")
- (version "0.12.0")
+ (version "2.4.0")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/dbus-cxx/dbus-cxx/"
- version "/dbus-cxx-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dbus-cxx/dbus-cxx")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1acsgpkd9v7b9jdc79ijmh9dbdfrzgkwkaff518i3zpk7y6g5mzw"))))
+ "0c9q2bjs4m66zq0qysyip8fnkvvjpj46rkjcvw15nhmfhzbq16ag"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "tools/libcppgenerate"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DENABLE_TESTS=ON"
- "-DENABLE_TOOLS=ON"
- "-DENABLE_GLIBMM=ON")))
- (inputs (list dbus
- libsigc++
- glibmm
- python
- popt
- expat))
- (native-inputs (list pkg-config m4))
+ (list #:configure-flags #~(list "-DBUILD_TESTING=ON"
+ "-DENABLE_TOOLS=ON"
+ "-DENABLE_GLIB_SUPPORT=ON"
+ "-DTOOLS_BUNDLED_CPPGENERATE=OFF")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; There is no /etc/machine-id file in the build
+ ;; environment.
+ (invoke "ctest" "-E" "test-machine-uuid-method")))))))
+ ;; These are propagated due to being referenced in headers and pkg-config
+ ;; .pc files.
+ (propagated-inputs (list glib libsigc++))
+ (inputs (list dbus expat libcppgenerate popt))
+ (native-inputs (list pkg-config))
(synopsis "C++ wrapper for dbus")
(description "Dbus-cxx is a C++ wrapper for dbus.\n
It exposes the C API to allow direct manipulation and
@@ -1236,7 +1248,7 @@ This package provide 2 utils:
Some codes examples can be find at:
@url{https://dbus-cxx.github.io/examples.html}")
(home-page "https://dbus-cxx.github.io/")
- (license license:gpl3)))
+ (license (list license:lgpl3+ license:bsd-3)))) ;dual licensed
(define-public sdbus-c++
;; Use the latest commit, which includes unreleased fixes to the pkg-config