summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-30 10:33:16 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-17 20:30:14 +0100
commit088aacb66eebf3698c43f867dbfb66601970853a (patch)
treeb0e0140f1b7864ae5f34c0b161f0eb7d4a43ed95 /gnu/packages/glib.scm
parentbe00aec4e43269aa3dcd807411b2c8f9c8b91e06 (diff)
downloadguix-patches-088aacb66eebf3698c43f867dbfb66601970853a.tar
guix-patches-088aacb66eebf3698c43f867dbfb66601970853a.tar.gz
gnu: telepathy-glib: Disable parallel tests.
* gnu/packages/glib.scm (telepathy-glib)[arguments]: Add #:parallel-tests?. Change-Id: I491b589b2e45c275ee3520436208beb5ee19964f
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 2e3c5f0e8b..ee44f8f403 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1138,6 +1138,11 @@ libraries. Examples include gtk+, webkit, libsoup and many more.")
;; EOFError: EOF read where object expected
;; make[2]: *** [Makefile:1906: _gen/register-dbus-glib-marshallers-body.h] Error 1
#:parallel-build? #f
+ ;; When spawned in parallel, the dbus daemons may fail to shut down
+ ;; cleanly. This issue appears to have been closed upstream due to low
+ ;; information, but still continues to haunt folks. See also
+ ;; <https://gitlab.freedesktop.org/telepathy/telepathy-glib/-/issues/134>.
+ #:parallel-tests? #f
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'disable-failing-tests