summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-24 23:28:10 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 20:51:43 -0400
commit1f96329f60292c180af8e6aeedd7ed2b0ef8a1a7 (patch)
treec0ea5095d504ba3d0efe30b13e78a243b74ece72 /gnu/packages/glib.scm
parent18f73d8041686e9ff307620eaa97bcd0cf064a8d (diff)
downloadguix-patches-1f96329f60292c180af8e6aeedd7ed2b0ef8a1a7.tar
guix-patches-1f96329f60292c180af8e6aeedd7ed2b0ef8a1a7.tar.gz
gnu: libsigc++: Update to 3.0.6.
* gnu/packages/glib.scm (libsigc++)[version]: Update to 3.0.6. [build-system]: Change from gnu to meson. [native-inputs]: Add mm-common, perl, libxml2 and libxslt. [inputs]: Add boost. [license]: Update to lgpl3+. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm32
1 files changed, 20 insertions, 12 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 493b3e5b64..9e472eb3a0 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -38,6 +38,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages docbook)
@@ -570,18 +571,25 @@ by GDBus included in Glib.")
(define libsigc++
(package
(name "libsigc++")
- (version "2.10.3")
+ (version "3.0.6")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/libsigc++/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "11j7j1jv4z58d9s7jvl42fnqa1dzl4idgil9r45cjv1w673dys0b"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("m4" ,m4)))
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/libsigc++/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1kn57b039lg20182lnchl1ys27vf34brn43f895cal8nc7sdq3mp"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("m4" ,m4)
+ ("mm-common" ,mm-common)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("xmllint" ,libxml2)
+ ("xsltproc" ,libxslt)))
+ (inputs
+ `(("boost" ,boost)))
(home-page "https://libsigcplusplus.github.io/libsigcplusplus/")
(synopsis "Type-safe callback system for standard C++")
(description
@@ -592,7 +600,7 @@ static or virtual.
It also contains adaptor classes for connection of dissimilar callbacks and
has an ease of use unmatched by other C++ callback libraries.")
- (license license:lgpl2.1+)))
+ (license license:lgpl3+)))
(define glibmm
(package