summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-04-02 15:18:30 +0800
committerLudovic Courtès <ludo@gnu.org>2016-04-16 11:43:06 +0200
commit0f795a0a539fbaed8cda95d9575a5cfdec62b83f (patch)
tree6b0bc5c8c1ec52a64c809fe7403c9d9613e43b59 /gnu/packages/glib.scm
parent944504b32ded87ea539667e30d8b770d6165367e (diff)
downloadguix-patches-0f795a0a539fbaed8cda95d9575a5cfdec62b83f.tar
guix-patches-0f795a0a539fbaed8cda95d9575a5cfdec62b83f.tar.gz
gnu: glib: Use modify-phases syntax.
* gnu/packages/glib.scm (glib)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d5ea9131e4..523116d8ac 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -160,29 +160,29 @@ shared NFS home directories.")
("perl" ,perl) ; needed by GIO tests
("bash" ,bash)))
(arguments
- '(#:phases (alist-cons-before
- 'build 'pre-build
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; For tests/gdatetime.c.
- (setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
-
- ;; Some tests want write access there.
- (setenv "XDG_CACHE_HOME" (getcwd))
-
- (substitute* '("glib/gspawn.c"
- "glib/tests/utils.c"
- "tests/spawn-test.c")
- (("/bin/sh")
- (string-append (assoc-ref inputs "bash") "/bin/sh")))
-
- ;; Disable a test that requires dbus.
- (substitute* "gio/tests/gdbus-serialization.c"
- (("g_test_add_func \
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; For tests/gdatetime.c.
+ (setenv "TZDIR"
+ (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+
+ ;; Some tests want write access there.
+ (setenv "XDG_CACHE_HOME" (getcwd))
+
+ (substitute* '("glib/gspawn.c"
+ "glib/tests/utils.c"
+ "tests/spawn-test.c")
+ (("/bin/sh")
+ (string-append (assoc-ref inputs "bash") "/bin/sh")))
+
+ ;; Disable a test that requires dbus.
+ (substitute* "gio/tests/gdbus-serialization.c"
+ (("g_test_add_func \
\\(\"/gdbus/message-serialize/double-array\", test_double_array\\);" all)
- (string-append "/* " all " */"))))
- %standard-phases)
+ (string-append "/* " all " */"))))))
;; Note: `--docdir' and `--htmldir' are not honored, so work around it.
#:configure-flags (list (string-append "--with-html-dir="