summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-27 22:03:44 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:24 -0500
commit33b28e9553435a58f8e34c785ff3fd451165b634 (patch)
tree243c25db42e56ee7b988b72323329b7d76197d87 /gnu/packages/gl.scm
parentc60449434bf64d42ba5c2de456823448088d3573 (diff)
downloadguix-patches-33b28e9553435a58f8e34c785ff3fd451165b634.tar
guix-patches-33b28e9553435a58f8e34c785ff3fd451165b634.tar.gz
gnu: mesa: Enable support for OpenGL ES 1.1 and 2.0.
* gnu/packages/gl.scm (mesa)[native-inputs]: Add python-libxml2. Remove TODO comment.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7756acbb58..19b53acd41 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -269,7 +269,6 @@ also known as DXTn or DXTC) for Mesa.")
("libelf" ,elfutils) ;required for r600 when using llvm
("libva" ,(force libva-without-mesa))
("libxml2" ,libxml2)
- ;; TODO: Add 'libxml2-python' for OpenGL ES 1.1 and 2.0 support
("libxrandr" ,libxrandr)
("libxvmc" ,libxvmc)
,@(match (%current-system)
@@ -291,6 +290,7 @@ also known as DXTn or DXTC) for Mesa.")
`()))
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
+ ("python-libxml2", python-libxml2) ;for OpenGL ES 1.1 and 2.0 support
("python-mako" ,python-mako)
("which" ,(@ (gnu packages base) which))))
(outputs '("out" "bin"))