summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-29 22:34:57 +0200
committerMarius Bakke <marius@gnu.org>2021-07-29 22:34:57 +0200
commitb029be2ee0f81cdcbc14240ff426408085ab0a40 (patch)
treeed6d0e1bfdadfd28e1eb804e43763b793baa0b42 /gnu/packages/gl.scm
parentbc55f3091bac4677df0cf020381c554921fea179 (diff)
parentffb381856d0c6cc1a557b789f6b377cfa17002a0 (diff)
downloadguix-patches-b029be2ee0f81cdcbc14240ff426408085ab0a40.tar
guix-patches-b029be2ee0f81cdcbc14240ff426408085ab0a40.tar.gz
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/bioinformatics.scm gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/emacs-xyz.scm gnu/packages/gpodder.scm gnu/packages/music.scm gnu/packages/patches/glibc-bootstrap-system.patch gnu/packages/python-xyz.scm gnu/packages/shells.scm gnu/packages/statistics.scm
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm25
1 files changed, 21 insertions, 4 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index cc5131b28d..92c8b59e45 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -484,10 +485,26 @@ from software emulation to complete hardware acceleration for modern GPUs.")
(package/inherit mesa-opencl
(name "mesa-opencl-icd")
(arguments
- (substitute-keyword-arguments (package-arguments mesa)
- ((#:configure-flags flags)
- `(cons "-Dgallium-opencl=icd"
- ,(delete "-Dgallium-opencl=standalone" flags)))))))
+ (substitute-keyword-arguments (package-arguments mesa)
+ ((#:configure-flags flags)
+ `(cons "-Dgallium-opencl=icd"
+ ,(delete "-Dgallium-opencl=standalone" flags)))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'mesa-icd-absolute-path
+ (lambda _
+ ;; Use absolute path for OpenCL platform library.
+ ;; Otherwise we would have to set LD_LIBRARY_PATH=LIBRARY_PATH
+ ;; for ICD in our applications to find OpenCL platform.
+ (use-modules (guix build utils)
+ (ice-9 textual-ports))
+ (let* ((out (assoc-ref %outputs "out"))
+ (mesa-icd (string-append out "/etc/OpenCL/vendors/mesa.icd"))
+ (old-path (call-with-input-file mesa-icd get-string-all))
+ (new-path (string-append out "/lib/" (string-trim-both old-path))))
+ (if (file-exists? new-path)
+ (call-with-output-file mesa-icd
+ (lambda (port) (format port "~a\n" new-path)))))))))))))
(define-public mesa-headers
(package/inherit mesa