summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-13 18:02:32 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-13 18:16:35 +0100
commit524f4becffd6a22318d3d28a97e497ef643c8ae0 (patch)
treed75c555326c6b94ae461150a03fec3470484deab /gnu/packages/gl.scm
parent7bed4df49a6534511cc0c48f76996c957c012c30 (diff)
downloadguix-patches-524f4becffd6a22318d3d28a97e497ef643c8ae0.tar
guix-patches-524f4becffd6a22318d3d28a97e497ef643c8ae0.tar.gz
gnu: Add GLEW.
* gnu/packages/gl.scm (glew): New variable.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index aa90c7e214..0eb2d2609e 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -196,6 +196,50 @@ allows Mesa to be used in many different environments ranging from software
emulation to complete hardware acceleration for modern GPUs.")
(license l:x11)))
+(define-public glew
+ (package
+ (name "glew")
+ (version "1.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/glew/glew-"
+ version
+ ".tgz"))
+ (sha256
+ (base32
+ "1mhkllxz49l1x680dmzrv2i82qjrq017sykah3xc90f2d8qcxfv9"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "config/Makefile.linux"
+ (("= cc") "= gcc")
+ (("/lib64") "/lib")))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-delete 'configure %standard-phases)
+ #:make-flags (list (string-append "GLEW_PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "GLEW_DEST="
+ (assoc-ref %outputs "out")))
+ #:tests? #f)) ;no 'check' target
+ (inputs
+ `(("libxi" ,libxi)
+ ("libxmu" ,libxmu)
+ ("libx11" ,libx11)
+ ("mesa" ,mesa)))
+
+ ;; <GL/glew.h> includes <GL/glu.h>.
+ (propagated-inputs `(("glu" ,glu)))
+
+ (home-page "http://glew.sourceforge.net/")
+ (synopsis "OpenGL extension loading library for C and C++")
+ (description
+ "The OpenGL Extension Wrangler Library (GLEW) is a C/C++ extension
+loading library. GLEW provides efficient run-time mechanisms for determining
+which OpenGL extensions are supported on the target platform. OpenGL core and
+extension functionality is exposed in a single header file.")
+ (license l:bsd-3)))
+
(define-public guile-opengl
(package
(name "guile-opengl")