summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-10-07 16:11:47 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-10-07 16:11:47 +0200
commit9e4a193b099fc4c8671891320adafe422d0d2f24 (patch)
tree5509e263520480c804ef847c5728ff2fdb0bc5c6 /gnu/packages/gl.scm
parent0be0f249eb033507d254fb8d2c267f0f1e509b8c (diff)
downloadguix-patches-9e4a193b099fc4c8671891320adafe422d0d2f24.tar
guix-patches-9e4a193b099fc4c8671891320adafe422d0d2f24.tar.gz
gnu: mesa: Update to 20.1.9.
* gnu/packages/gl.scm (mesa): Update to 20.1.9. [arguments]<#:phases>[fix-tests]: New phase.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e033ef721e..4e372c530b 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -234,7 +234,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "20.1.8")
+ (version "20.1.9")
(source
(origin
(method url-fetch)
@@ -246,7 +246,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "1252mgwiy05nz8mm4gjkzmnjfvdz5yv1shnsr837cdnan86dvsad"))
+ "10kk8a8k7f4ip8yaiqdyrx162nbw8pw4h3b4hs4ha8mpd43wlldj"))
(patches
(search-patches "mesa-skip-disk-cache-test.patch"))))
(build-system meson-build-system)
@@ -358,6 +358,12 @@ also known as DXTn or DXTC) for Mesa.")
(("'u_format_test',") ""))
#t)))
'())
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; See <https://gitlab.freedesktop.org/mesa/mesa/-/issues/3181>.
+ (substitute* "src/compiler/glsl/glcpp/tests/084-unbalanced-parentheses.c.expected"
+ (("unexpected \\$end") "unexpected end of file"))
+ #t))
(add-before 'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))