summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-11 11:48:26 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:34 +0200
commit784610d6d65bfb827e173ae087f2a902f5f80cee (patch)
tree22efdae303f23f35ab8b10253d6cbb3f93248289 /gnu/packages/ghostscript.scm
parentf1a68cbb72406867e400b99cc66f516b0ae8580c (diff)
downloadguix-patches-784610d6d65bfb827e173ae087f2a902f5f80cee.tar
guix-patches-784610d6d65bfb827e173ae087f2a902f5f80cee.tar.gz
gnu: libpaper: Disable tests for the Hurd.
* gnu/packages/ghostscript.scm (libpaper)[arguments]: When building for the Hurd, set #:tests? to #false.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 8d35f1195c..94807fdd94 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020, 2022 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -89,9 +89,11 @@ Consortium standard (ICC), approved as ISO 15076-1.")
(native-inputs
(list help2man))
(arguments
- '(#:configure-flags '("--disable-static"
- ;; Tests require a relocatable build.
- "--enable-relocatable")))
+ (list #:configure-flags ''("--disable-static"
+ ;; Tests require a relocatable build.
+ "--enable-relocatable")
+ ;; --enable-relocate is broken on the Hurd
+ #:tests? (not (target-hurd?))))
(outputs '("out" "debug"))
(home-page "https://github.com/rrthomas/libpaper")
(synopsis "Library for handling paper sizes")