summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:04 +0200
commit67fb8efdf782592c133726a1ab7bc6692259e385 (patch)
tree3c6b8ceb3322eee2a4826ebd6a116da8cbee51f8 /gnu/packages/ghostscript.scm
parentb29bd4d35e26951c719f31fc505c7c2bc566b4e1 (diff)
downloadguix-patches-67fb8efdf782592c133726a1ab7bc6692259e385.tar
guix-patches-67fb8efdf782592c133726a1ab7bc6692259e385.tar.gz
gnu: ghostscript: Fix CVE-2023-36664.
* gnu/packages/ghostscript.scm (ghostscript/fixed): New variable. (ghostscript)[replacement]: Assign it to new field. * gnu/packages/patches/ghostscript-CVE-2023-36664.patch, gnu/packages/patches/ghostscript-CVE-2023-36664-fixup.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 1813cc367e..8d35f1195c 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -145,6 +145,7 @@ printing, and psresize, for adjusting page sizes.")
(package
(name "ghostscript")
(version "9.56.1")
+ (replacement ghostscript/fixed)
(source
(origin
(method url-fetch)
@@ -266,6 +267,12 @@ output file formats and printers.")
(home-page "https://www.ghostscript.com/")
(license license:agpl3+)))
+(define ghostscript/fixed
+ (package-with-patches
+ ghostscript
+ (search-patches "ghostscript-CVE-2023-36664.patch"
+ "ghostscript-CVE-2023-36664-fixup.patch")))
+
(define-public ghostscript/x
(package/inherit ghostscript
(name (string-append (package-name ghostscript) "-with-x"))