summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-04-30 21:47:37 +0200
committerAndreas Enge <andreas@enge.fr>2024-05-12 20:40:29 +0200
commit89cd778f6a45cd9b43a4dc1f236dcd0a87af955c (patch)
treeecc66e67697cec87d9b3f9984afde8cb9ab15775 /gnu/packages/geo.scm
parent7b2e7ff25a58412757100d401b50f6e39b3da354 (diff)
downloadguix-patches-89cd778f6a45cd9b43a4dc1f236dcd0a87af955c.tar
guix-patches-89cd778f6a45cd9b43a4dc1f236dcd0a87af955c.tar.gz
gnu: Add python-overpass.
* gnu/packages/geo.scm (python-overpass): New variable. Change-Id: Icd7a66ec6acd2e213bfd6920a1d71c1e0e815695 Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 9010c2444a..7da0a7d7ef 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2022 Roman Scherer <roman.scherer@burningswell.com>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -986,6 +987,30 @@ enables you to easily do operations in Python that would otherwise
require a spatial database such as PostGIS.")
(license license:bsd-3)))
+(define-public python-overpass
+ (package
+ (name "python-overpass")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "overpass" version))
+ (sha256
+ (base32 "0l2n01j0vslag8cf3sp7jif0d4ql6i99fvfv2mgc3ajws69aqzr6"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; tests disabled, as they require network
+ (list #:tests? #f))
+ (propagated-inputs (list python-geojson
+ python-requests
+ python-shapely))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/mvexel/overpass-api-python-wrapper")
+ (synopsis "Python wrapper for the OpenStreetMap Overpass API")
+ (description "This package provides python-overpass, a Python wrapper
+for the @code{OpenStreetMap} Overpass API.")
+ (license license:asl2.0)))
+
(define-public python-ogr2osm
(package
(name "python-ogr2osm")