summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-08 09:06:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 09:06:14 +0200
commit1c94392a13cbdf87e03a644633eb775bf45694a1 (patch)
tree74f11038dfc5f9d9db06660b1087253b28c5434f /gnu/packages/geo.scm
parentdd87bbb2b78b279248aaff15c0706fcd6d8cd7bb (diff)
parent9d25ee30b188f9202cc14f7cd25ba8a1c3ec1a72 (diff)
downloadguix-patches-1c94392a13cbdf87e03a644633eb775bf45694a1.tar
guix-patches-1c94392a13cbdf87e03a644633eb775bf45694a1.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 938720f928..7532943839 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1181,7 +1181,7 @@ to create databases that are optimized for rendering/tile/map-services.")
(define-public libosmium
(package
(name "libosmium")
- (version "2.15.6")
+ (version "2.17.1")
(source
(origin
(method git-fetch)
@@ -1190,7 +1190,7 @@ to create databases that are optimized for rendering/tile/map-services.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0rqy18bbakp41f44y5id9ixh0ar2dby46z17p4115z8k1vv9znq2"))))
+ (base32 "0xw71lrw4q4sdm51rl0zg87ywxfkxbw9h52zqim0z0xl5qh5q8xf"))))
(build-system cmake-build-system)
(propagated-inputs
`(("boost" ,boost)
@@ -1214,7 +1214,7 @@ OpenStreetMap data.")
(define-public osm2pgsql
(package
(name "osm2pgsql")
- (version "1.2.2")
+ (version "1.5.1")
(source
(origin
(method git-fetch)
@@ -1223,7 +1223,7 @@ OpenStreetMap data.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1j35aa8qinhavliqi5pdm0viyi7lm5xyk402rliaxxs1r2hbsafn"))
+ (base32 "0i18mskcs087dn3f3h9n7j0wafn8502m0h13mrjwin38xsz0crfj"))
(modules '((guix build utils)))
(snippet
'(begin