summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-26 17:11:20 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-26 17:11:20 +0200
commit7097e98586df3110b80943a88c27804d65f214fa (patch)
tree2e244b9fc19acc569d6abd42306aaf013f02da0d /gnu/packages/geo.scm
parent15870cc08d20501e3526fa892111a43ae9e3e02f (diff)
parent4577f3c6b60ea100e521c246fb169d6c05214b20 (diff)
downloadguix-patches-7097e98586df3110b80943a88c27804d65f214fa.tar
guix-patches-7097e98586df3110b80943a88c27804d65f214fa.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c2569c27d4..0c9240eea7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -715,9 +715,14 @@ pyproj, Rtree, and Shapely.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest"
- ; Disable test that fails with
- ; NotImplementedError in pandas.
- "-k" "not test_fillna_no_op_returns_copy"
+ ; Disable tests that fail due to incompatibilities
+ ; with our pandas version.
+ "-k"
+ (string-append
+ "not test_getitem_invalid"
+ " and not test_value_counts"
+ " and not test_setitem_invalid"
+ " and not test_insert_invalid")
; Disable tests that require internet access.
"-m" "not web")))))))
(propagated-inputs