summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-11-19 21:10:12 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-20 18:23:15 +0100
commit4d02165992b9c516530f0b7aea147b379887dc62 (patch)
tree3d59d3475061b0e73cb47b4fd1258f8aa6c18686 /gnu/packages/geo.scm
parentb182e136384725ffafaa2c5e344ffc2135021c68 (diff)
downloadguix-patches-4d02165992b9c516530f0b7aea147b379887dc62.tar
guix-patches-4d02165992b9c516530f0b7aea147b379887dc62.tar.gz
gnu: opencpn: Update to 5.2.4.
* gnu/packages/geo.scm (opencpn): Update to 5.2.4. [arguments]: Update 'configure-flag' and 'fix-build' phase.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index f07b5e4b95..9b34da8a48 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2014,7 +2014,7 @@ exchanged form one Spatial DBMS and the other.")
(define-public opencpn
(package
(name "opencpn")
- (version "5.0.0")
+ (version "5.2.4")
(source
(origin
(method git-fetch)
@@ -2023,7 +2023,7 @@ exchanged form one Spatial DBMS and the other.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1xv3h6svw9aay5ixpql231md3pf00qxvhg62z88daraf18hlkfja"))))
+ (base32 "0ffx0lmz1mp5433zqyxigy4qqav32xprpagd66krvihkyvqp2y6y"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -2049,20 +2049,23 @@ exchanged form one Spatial DBMS and the other.")
("xz" ,xz)
("zlib" ,zlib)))
(arguments
- `(#:configure-flags '("-DENABLE_PORTAUDIO=ON"
- "-DENABLE_SNDFILE=ON"
- "-DBUNDLE_TCDATA=ON"
- "-DBUNDLE_GSHHS=CRUDE"
- "-DCMAKE_C_FLAGS=-fcommon")
+ `(#:configure-flags '("-DOCPN_USE_BUNDLED_LIBS=OFF"
+ "-DOCPN_ENABLE_PORTAUDIO=ON"
+ "-DOCPN_ENABLE_SNDFILE=ON"
+ "-DOCPN_BUNDLE_TCDATA=ON"
+ "-DOCPN_BUNDLE_GSHHS=ON")
#:tests? #f ; No tests defined
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-build
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "CMakeLists.txt"
- (("set\\(wxWidgets_CONFIG_OPTIONS.*--toolkit=gtk3" all)
- (string-append all " --libs all")))
- #t)))))
+ (("wx-32.c; cc")
+ "wx-32.c; gcc")
+ (("\"/bin/sh\" \"-c\"")
+ (string-append "\"" (which "bash") "\" \"-c\""))
+ (("include\\(TargetSetup\\)")
+ "set(PKG_TARGET \"guix\")\nset(PKG_TARGET_VERSION 1)")))))))
(synopsis "Chart plotter and marine GPS navigation software")
(description
"OpenCPN is a chart plotter and marine navigation software designed to be