summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:02:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:02:42 +0300
commit481b0923f455af6da8aff859c14402ac484a2ca2 (patch)
tree27781b898ba7cebc5eb2cd307bc7da2c73898131 /gnu/packages/geo.scm
parent7bef1f6cd5e59a7c62979d6e9322c55e4941f4c4 (diff)
downloadguix-patches-481b0923f455af6da8aff859c14402ac484a2ca2.tar
guix-patches-481b0923f455af6da8aff859c14402ac484a2ca2.tar.gz
gnu: Add python-geopy.
* gnu/packages/geo.scm (python-geopy): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 421ce8df36..3b08b283b9 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -86,6 +86,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -2114,3 +2115,34 @@ architecture.")
(description
"This is a python implementation of the geodesic routines in GeographicLib.")
(license license:expat)))
+
+(define-public python-geopy
+ (package
+ (name "python-geopy")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "geopy" version))
+ (sha256
+ (base32
+ "0fx0cv0kgbvynpmjgsvq2fpsyngd5idiscdn8pd5201f1ngii3mq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-geographiclib" ,python-geographiclib)))
+ (native-inputs
+ `(("python-async-generator" ,python-async-generator)
+ ("python-coverage" ,python-coverage)
+ ("python-flake8" ,python-flake8)
+ ("python-isort" ,python-isort)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-aiohttp" ,python-pytest-aiohttp)
+ ("python-readme-renderer" ,python-readme-renderer)
+ ("python-pytz" ,python-pytz)))
+ (home-page "https://github.com/geopy/geopy")
+ (synopsis "Geocoding library for Python")
+ (description "@code{geopy} is a Python client for several popular geocoding
+web services. @code{geopy} makes it easy for Python developers to locate the
+coordinates of addresses, cities, countries, and landmarks across the globe
+using third-party geocoders and other data sources.")
+ (license license:expat)))